activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "andre.nas" <moonfl...@yahoo.com.au>
Subject Re: ActiveMQ not running using SMF on solaris
Date Wed, 14 Jul 2010 06:37:28 GMT

Not sur this is the best solution or not, after creating script for running
in background, SMF running ok.


andre.nas wrote:
> 
> Dear all, 
> Maybe someone experience using SMF on solaris. I make SMF Manifest but,
> after couple minute the activemq is under maintenance. If i run manually
> everthing fine, please advice me. 
> 
> THanks in Advance.
> Andre
> 
> Here is my manifest :
> 
> 
> <?xml version="1.0"?>
> <!DOCTYPE service_bundle SYSTEM
> "/usr/share/lib/xml/dtd/service_bundle.dtd.1">
> 
> <service_bundle type='manifest' name='Active MQ'>
> 
> <service
>         name='network/http'
>         type='service'
>         version='1'>
> 
>         <!--
>           Because we may have multiple instances of network/http
>           provided by different implementations, we keep dependencies
>           and methods within the instance.
>         -->
> 
>         <instance name='activemq' enabled='false'>
>                 <!--
>                   Wait for network interfaces to be initialized.
>                 -->
>                 <dependency name='network'
>                     grouping='require_all'
>                     restart_on='error'
>                     type='service'>
>                     <service_fmri value='svc:/milestone/network:default'/>
>                 </dependency>
> 
>                 <!--
>                   Wait for all local filesystems to be mounted.
>                 -->
> 
>         <dependency name='filesystem-local'
>                     grouping='require_all'
>                     restart_on='none'
>                     type='service'>
>                     <service_fmri
>                         value='svc:/system/filesystem/local:default'/>
>                 </dependency>
> 
>                 <!--
>                   Wait for automounting to be available, as we may be
>                   serving data from home directories or other remote
>                   filesystems.
>                 -->
> 
>                 <dependency name='autofs'
>                     grouping='optional_all'
>                     restart_on='error'
>                     type='service'>
>                     <service_fmri
>                         value='svc:/system/filesystem/autofs:default'/>
>                 </dependency>
> 
>                 <!-- restrict privileges and run as user root -->
>                 <method_context>
>                        <method_credential
>                                 user='webservd' group='webservd'
>                                 privileges='basic,net_privaddr' />
>                 </method_context>
> 
>                 <exec_method
>                         type='method'
>                         name='start'
>                         exec='/opt/activemq/bin/activemq-admin start'
>                         timeout_seconds='120' >
>                 </exec_method>
> 
>                 <exec_method
>                         type='method'
>                         name='stop'
>                         exec='/opt/activemq/bin/activemq-admin stop'
>                         timeout_seconds='120' >
>                 </exec_method>
> 
>                 <property_group name='httpd' type='application'>
>                         <stability value='Evolving' />
>                         <propval name='ssl' type='boolean' value='false'
> />
>                 </property_group>
> 
>                 <property_group name='startd' type='framework'>
>                         <!-- sub-process core dumps shouldn't restart
>                                 session -->
>                         <propval name='ignore_error' type='astring'
>                                 value='core,signal' />
>                 </property_group>
> 
>         </instance>
> 
>         <stability value='Evolving' />
> 
>         <template>
>                 <common_name>
>                         <loctext xml:lang='C'>Active MQ</loctext>
>                 </common_name>
>                 <documentation>
>                   <doc_link name="Active MQ"
> uri="http://activemq.apache.org/getting-started.html"/>
>                 </documentation>
>         </template>
> </service>
> 
> </service_bundle>
> 
> 
> --- 
> My SMF log.
> 
> INFO  /admin                         - Initializing Spring
> FrameworkServlet 'dispatcher'
> INFO  log                            - ActiveMQ Console at
> http://0.0.0.0:8161/admin
> INFO  log                            - ActiveMQ Web Demos at
> http://0.0.0.0:8161/demo
> INFO  log                            - RESTful file access application at
> http://0.0.0.0:8161/fileserver
> INFO  log                            - Started
> SelectChannelConnector@0.0.0.0:8161
> [ Jul 12 18:46:56 Method or service exit timed out.  Killing contract 325
> ]
> [ Jul 12 18:46:56 Method "start" failed due to signal KILL ]
> [ Jul 12 18:51:47 Leaving maintenance because disable requested. ]
> 

-- 
View this message in context: http://old.nabble.com/ActiveMQ-not-running-using-SMF-on-solaris-tp29145795p29158745.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message