activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zagiatakrapovic <zagiatakrapo...@gmx.ch>
Subject Re: Solaris SPARC, queued messages never handled
Date Sat, 03 Jul 2010 18:19:03 GMT

hmmm using the example producer/consumer, sounds great to me, I will try
that.
Usually I'm running 5.3.2 but as I said, I tried all version back to 5.0 .

thanks for your input !


Stan Lewis-4 wrote:
> 
> What version are you running?  Can you post the exact code the
> consumer is using to connect and register it's message listener?  Also
> does this behavior happen with the example producer/consumer shipped
> with activemq?
> 
> On Sat, Jul 3, 2010 at 6:51 AM, zagiatakrapovic <zagiatakrapovic@gmx.ch>
> wrote:
>>
>> Hi guys,
>>
>> I experience a very strange problem. The software I'm maintaining is
>> running
>> under Windows, Linux and Solaris (x86, SPARC). Now with the new release
>> everything seems fine except Solaris SPARC (v.10 and v.9). Under Solaris
>> the
>> queued messages are never processed. If I copy the very same installation
>> folder to a Linux machine, everything works fine!
>> We are using JMS to pass messages from one host to another (only in one
>> direction) with help of a ssl-queue.
>> In order to find the problem we turned on debugging in activemq and our
>> software. We investigated the handshake, the transmission and the queue
>> and
>> its messages. Everything works fine. The messages are received and queued
>> properly. But there is never a callback to the "onMessage()" method,
>> registered as consumer of the queue (yes I have seen and tried: "I am not
>> receiving any messages - what is wrong?").
>>
>> We tried to switch of 'clientAuth' in ssl and even went to pure tcp://
>> connections with no changes of the behaviour.
>>
>> We thought that one possible problem with Solaris could be the long TCP
>> timeout for connections with TIME_WAIT status. Even the program was
>> stopped
>> the queue connections were still present (in netstat) for about 2h. A
>> restart of the program led to activemq connection problems, we are
>> handling
>> this issue by collecting the connection and disposing the queue.
>> Nevertheless we corrected that using 'ndd' (after a long stfw-session).
>> The
>> timeout is now at the min. of 10s.
>> I think we tried out every possible argument of tcp:// and ssl://, with
>> no
>> luck.
>> Debugging with JMX did not work properly on Solaris (using FUSE,
>> ActiveMQBrowser), we couldn't figure out how to properly set it up (we
>> tried
>> the url argument and the JVM argument) without changing code (querying
>> the
>> web has shown that we are not the only persons failing on this). JConsole
>> did work out and we could verify that messages are received at least.
>>
>> The worst thing is we have no clue were to look further. There are no
>> error
>> messages at all.
>> We also tried other versions of the activemq: 5.0 - 5.3.2, same result.
>>
>> Before we start to check every 'diff' in the new release compared to the
>> old
>> working one, I thought maybe someone could give me a hint were to look or
>> how to collect more information about the problem.
>>
>> I know this short summary is everything else than complete or precise,
>> hence
>> I will be pleased to answer any further questions you may have ....
>> --
>> View this message in context:
>> http://old.nabble.com/Solaris-SPARC%2C-queued-messages-never-handled-tp29063239p29063239.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>>
> 
> 

-- 
View this message in context: http://old.nabble.com/Solaris-SPARC%2C-queued-messages-never-handled-tp29063239p29065320.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message