activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From valliram <valliap...@gmail.com>
Subject setJMSReplyTo is not transfered to broker
Date Thu, 01 Jul 2010 11:48:06 GMT

message to send: ActiveMQTextMessage {commandId = 0, responseRequired =
false, m
essageId = ID:fasym013-2232-1277981792857-0:0:1:1:1, originalDestination =
null,
 originalTransactionId = null, producerId = null, destination = queue://test
Queue, transactionId = null, expiration = 0, timestamp = 1277981793107,
arrival
= 0, brokerInTime = 0, brokerOutTime = 0, correlationId = 251daee6696d183d,
repl
yTo = temp-queue://ID:fasym013-2232-1277981792857-0:0:1, persistent = true,
type
 = null, priority = 4, groupID = null, groupSequence = 0, targetConsumerId =
nul
l, compressed = false, userID = null, content = null, marshalledProperties =
nul
l, dataStructure = null, redeliveryCounter = 0, size = 0, properties = null,
rea
dOnlyProperties = false, readOnlyBody = false, droppable = false, text =
get-id:
<?xml version="1.0" encoding="UTF-8"?>...monds-build>}
receiveaddress: temp-queue://ID:fasym013-2232-1277981792857-0:0:1

In that the replyto is with the value,

But in the broker using JMS replyto is null and

message received: ActiveMQTextMessage {commandId = 5, responseRequir
ed = true, messageId = ID:fasym013-2081-1277980931049-0:0:1:1:1,
originalDestina
tion = null, originalTransactionId = null, producerId =
ID:fasym013-2081-1277980
931049-0:0:1:1, destination = queue://test, transactionId = null, expir
ation = 0, timestamp = 1277980931299, arrival = 0, brokerInTime =
1277980931299,
 brokerOutTime = 1277980931315, correlationId = null, replyTo = null,
persistent
 = true, type = null, priority = 4, groupID = null, groupSequence = 0,
targetCon
sumerId = null, compressed = false, userID = null, content = null,
marshalledPro
perties = null, dataStructure = null, redeliveryCounter = 0, size = 0,
propertie
s = null, readOnlyProperties = true, readOnlyBody = true, droppable = false,
tex
t = get-id:<?xml version="1.0" encoding="UTF-8"?>...monds-build>}

the replyto is null.

Why is the replyto is not passed to broker?


The replyto is set to temporary queue


-- 
View this message in context: http://old.nabble.com/setJMSReplyTo-is-not-transfered-to-broker-tp29044770p29044770.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message