activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: Unable to build ActiveMQ code
Date Wed, 23 Jun 2010 12:53:21 GMT
there is a problem with the pom for ftpserver, such that its transitive
dependencies are not pulled in. mvn -X should point you to the problem
property...

There is some detail in
https://issues.apache.org/jira/browse/FTPSERVER-368that is fixes but
pending a release.

You can make the manual mods to your local copy of the pom to work around
this issue.

Also, I think maven 2.0.2 is not as picky. What version of maven are you
using?


On 23 June 2010 13:30, codescoder <bukka.ramu@gmail.com> wrote:

>
> Hi there,
> i am trying to build the activemq code in my local machine,i have installed
> svn and mvn (both are working fine)
> i went to acivemq directory and given command " export MAVEN_OPTS=-Xmx512M
> -XX:MaxPermSize=128M
> mvn -Dtest=false install"
> its failing in ActiveMQ :: Core and i am getting error as
>
> "[ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-compiler-plugin:2.
> 0.2:testCompile (default-testCompile) on project activemq-core: Compilation
> fail
> ure: Compilation failure:
> F:\ActiveMQ\activemq-core\src\test\java\org\apache\activemq\blob\FTPTe
> stSupport.java:[13,35] package org.apache.ftpserver.ftplet does not exist"
>
> --
> View this message in context:
> http://old.nabble.com/Unable-to-build-ActiveMQ-code-tp28971166p28971166.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>


-- 
http://blog.garytully.com

Open Source Integration
http://fusesource.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message