activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: How to enable HTTPS when SSL is working ?
Date Thu, 03 Jun 2010 13:28:31 GMT
Hi,

this shouldn't affect https transport as it has it's own embedded Jetty
server. Did you try setting ssl parameters using system properties, as I'm
not sure https transport can use <sslContext> at the moment?

Cheers
--
Dejan Bosanac - http://twitter.com/dejanb

Open Source Integration - http://fusesource.com/
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Thu, Jun 3, 2010 at 5:29 AM, munger <max.unger@sungard.com> wrote:

>
> Replying to myself:
>
> The problem was that my web server (Jetty) didn't have any SSL connector
> configured.... So i added it to my configuration. However, there still a
> problem i get a 404 error from my server, here is my client log:
>
>
> listenerContainer-1, WRITE: TLSv1 Handshake, length = 32
> listenerContainer-1, WRITE: TLSv1 Application Data, length = 142
> listenerContainer-1, READ: TLSv1 Application Data, length = 182
> 11:24:37,117  INFO <listenerContainer-1> Could not refresh JMS Connection -
> retrying in 5000 ms
> javax.jms.JMSException: Could not connect to broker URL:
> https://localhost:443. Reason: java.io.IOException: Failed to perform GET
> on: https://localhost:443 as response was: 404
>        at
>
> org.apache.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:35)
>        at
>
> org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:280)
>        at
>
> org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:224)
>        at
>
> org.apache.activemq.ActiveMQConnectionFactory.createConnection(ActiveMQConnectionFactory.java:172)
>        at
>
> org.apache.activemq.pool.PooledConnectionFactory.createConnection(PooledConnectionFactory.java:125)
>        at
>
> org.apache.activemq.pool.PooledConnectionFactory.createConnection(PooledConnectionFactory.java:110)
>        at
>
> org.apache.activemq.pool.PooledConnectionFactory.createConnection(PooledConnectionFactory.java:81)
>        at
>
> org.springframework.jms.support.JmsAccessor.createConnection(JmsAccessor.java:184)
>        at
>
> org.springframework.jms.listener.AbstractJmsListeningContainer.createSharedConnection(AbstractJmsListeningContainer.java:401)
>        at
>
> org.springframework.jms.listener.AbstractJmsListeningContainer.refreshSharedConnection(AbstractJmsListeningContainer.java:386)
>        at
>
> org.springframework.jms.listener.DefaultMessageListenerContainer.refreshConnectionUntilSuccessful(DefaultMessageListenerContainer.java:782)
>        at
>
> org.springframework.jms.listener.DefaultMessageListenerContainer.recoverAfterListenerSetupFailure(DefaultMessageListenerContainer.java:764)
>        at
>
> org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.run(DefaultMessageListenerContainer.java:892)
>        at java.lang.Thread.run(Thread.java:619)
> Caused by: java.io.IOException: Failed to perform GET on:
> https://localhost:443 as response was: 404
>        at
>
> org.apache.activemq.transport.http.HttpClientTransport.doStart(HttpClientTransport.java:183)
>        at
> org.apache.activemq.util.ServiceSupport.start(ServiceSupport.java:53)
>        at
>
> org.apache.activemq.transport.TransportFilter.start(TransportFilter.java:57)
>        at
>
> org.apache.activemq.transport.TransportFilter.start(TransportFilter.java:57)
>        at
>
> org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:260)
>        ... 12 more
> --
> View this message in context:
> http://old.nabble.com/How-to-enable-HTTPS-when-SSL-is-working---tp28755706p28765179.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message