activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: Why does ActiveMQ's performance on server so poor?
Date Wed, 09 Jun 2010 17:34:14 GMT
difference in fsync behavior? see:
http://old.nabble.com/slow-KahaDB-access-td26172918.html#a26213644

On 9 June 2010 15:02, Tiger_ <yanghuw@163.com> wrote:

>
> Hi everybody,
>    I test ActiveMQ on my PC (Core2 E8400, 2G RAM, CentOS 64,
> jdk1.6_0_20_x86_64), the throughput is about 1200msgs/sec(persistent) or
> 7000msgs/sec(Non-persistent).
>
> But on my server (Xeon E7420 * 4,  16G RAM, CentOS 64, jdk1.6_0_20_x86_64),
> the throughput is about 90msgs/sec(persistent) or
> 150msgs/sec(Non-persistent).
>
> And I found I/O blocking on one core.
>
> top - 05:31:12 up 22:30,  5 users,  load average: 1.72, 1.77, 1.71
> Tasks: 301 total,   1 running, 299 sleeping,   1 stopped,   0 zombie
> Cpu0  :  0.7%us,  0.0%sy,  0.0%ni, 99.3%id,  0.0%wa,  0.0%hi,  0.0%si,
> 0.0%st
> Cpu1  :  0.3%us,  0.3%sy,  0.0%ni, 99.3%id,  0.0%wa,  0.0%hi,  0.0%si,
> 0.0%st
> Cpu2  :  0.3%us,  0.0%sy,  0.0%ni, 99.7%id,  0.0%wa,  0.0%hi,  0.0%si,
> 0.0%st
> Cpu3  :  1.0%us,  0.0%sy,  0.0%ni, 99.0%id,  0.0%wa,  0.0%hi,  0.0%si,
> 0.0%st
> Cpu4  :  0.3%us,  0.0%sy,  0.0%ni, 99.7%id,  0.0%wa,  0.0%hi,  0.0%si,
> 0.0%st
> Cpu5  :  0.7%us,  0.3%sy,  0.0%ni,  1.3%id, 97.3%wa,  0.0%hi,  0.3%si,
> 0.0%st
> Cpu6  :  0.0%us,  0.0%sy,  0.0%ni,100.0%id,  0.0%wa,  0.0%hi,  0.0%si,
> 0.0%st
> Cpu7  :  0.3%us,  0.0%sy,  0.0%ni, 99.3%id,  0.0%wa,  0.0%hi,  0.3%si,
> 0.0%st
> Cpu8  :  0.3%us,  0.0%sy,  0.0%ni, 99.7%id,  0.0%wa,  0.0%hi,  0.0%si,
> 0.0%st
> Cpu9  :  0.3%us,  0.0%sy,  0.0%ni, 99.0%id,  0.3%wa,  0.0%hi,  0.3%si,
> 0.0%st
> Cpu10 :  1.0%us,  0.3%sy,  0.0%ni, 98.7%id,  0.0%wa,  0.0%hi,  0.0%si,
> 0.0%st
> Cpu11 :  0.3%us,  0.0%sy,  0.0%ni, 99.7%id,  0.0%wa,  0.0%hi,  0.0%si,
> 0.0%st
> Cpu12 :  0.7%us,  0.0%sy,  0.0%ni, 99.3%id,  0.0%wa,  0.0%hi,  0.0%si,
> 0.0%st
> Cpu13 :  0.3%us,  0.0%sy,  0.0%ni, 99.7%id,  0.0%wa,  0.0%hi,  0.0%si,
> 0.0%st
> Cpu14 :  0.3%us,  0.7%sy,  0.0%ni, 99.0%id,  0.0%wa,  0.0%hi,  0.0%si,
> 0.0%st
> Cpu15 :  2.0%us,  0.7%sy,  0.0%ni, 97.3%id,  0.0%wa,  0.0%hi,  0.0%si,
> 0.0%st
> --
> View this message in context:
> http://old.nabble.com/Why-does-ActiveMQ%27s-performance-on-server-so-poor--tp28830825p28830825.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>


-- 
http://blog.garytully.com

Open Source Integration
http://fusesource.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message