activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pavel Moravec <pavel.mora...@acision.com>
Subject ActiveMQ 5.3.2 stalled emails in queue
Date Mon, 28 Jun 2010 11:02:36 GMT

Hello, has somebody met stalled persistent emails in ActiveMQ 5.3.2?
Something like AMQ-2009? As that should be fixed in ActiveMQ 5.3 while we
see that in 5.3.2. In our case, ActiveMQ receives emails from James server,
puts them into a queue where there are 50 consumers all with prefetch set to
1. To resolve the problem of stalled emails, it was enough to delete the
very first (oldest) email stored in the queue and restart ActiveMQ. So it
seems some particular email in some particular situation stucks ActiveMQ.

During the crazy time I was able to gather Java thread dump 
http://old.nabble.com/file/p29008536/thread_dump.txt.gz thread_dump.txt.gz 
where I see one peculiar thing:

thread "ActiveMQ Transport: tcp:///127.0.0.1:59468" locks 0x0000002aa1c3c770
while other 15 threads are waiting for the lock.

My questions are:
1) Have you experienced similar problems? What was the cause and resolution?
2) Is the thread dump ok? Esp. the locks? s for me it is strange that one
transport thread (I suppose towards the consumers) blocks 15 others..

Thanks in advance for any help.
-- 
View this message in context: http://old.nabble.com/ActiveMQ-5.3.2-stalled-emails-in-queue-tp29008536p29008536.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message