activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: activemq-cpp 3.2.0 vs2005-build directory is missing
Date Mon, 28 Jun 2010 12:34:13 GMT
On Mon, 2010-06-28 at 02:22 -0700, Sodan wrote:
> is there a way to test if a map is empty ?
> 

You could call getMapNames() and see if the returned vector is empty.

Regards


> Søren
> 
> 
> 
> Timothy Bish wrote:
> > 
> > On Fri, 2010-06-25 at 05:05 -0700, Sodan wrote:
> >> Hi again
> >> 
> >> Spent a number of hours trying to figure this out. I get a certain type
> >> of
> >> message, call it "PT" and many of these messages are ok, but then
> >> suddenly I
> >> get a message of that type, which mas an empty map. As soon as I do any
> >> type
> >> of operation on the message map, it fails...
> >> I also get many other types of messages, and they are all fine.
> >> 
> >> ?
> >> Søren
> > 
> > I've not been able to find any issue with sending empty Maps using CMS,
> > if you can create a test app that can demonstrate the issue I'd be happy
> > to look into it.
> > 
> > Regards
> > 
> > -- 
> > Tim Bish
> > 
> > Open Source Integration: http://fusesource.com
> > ActiveMQ in Action: http://www.manning.com/snyder/
> > 
> > Follow me on Twitter: http://twitter.com/tabish121
> > My Blog: http://timbish.blogspot.com/
> > 
> > 
> > 
> 

-- 
Tim Bish

Open Source Integration: http://fusesource.com
ActiveMQ in Action: http://www.manning.com/snyder/

Follow me on Twitter: http://twitter.com/tabish121
My Blog: http://timbish.blogspot.com/


Mime
View raw message