activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruce Snyder <bruce.sny...@gmail.com>
Subject Re: activemq 5.3.1 SEVERE: NATURAL JSON notation configured, but JAXB RI 2.1.10 not found.
Date Wed, 05 May 2010 21:39:12 GMT
On Wed, May 5, 2010 at 7:52 AM, dgd01 <dorothea_davis@homedepot.com> wrote:
>
> Getting the following error after upgrading from 5.3.0.0 to 5.3.1.0
> java 1.6
> ocurring on 2 types of linux servers z-linux and redhat 5.1 linux
>
> Please let me know what additional detail you might need to help me resolve
> this issue.
>
> Thanks for your help.
>
> SEVERE: NATURAL JSON notation configured, but JAXB RI 2.1.10 not found. For
> the recent builds to get this working correctly, you need even at least JAXB
> version 2.1.12. Please add it to your classpath!
> May 3, 2010 6:07:55 PM com.sun.jersey.core.spi.component.ProviderFactory
> __getComponentProvider
> SEVERE: The provider class, class
> org.apache.camel.web.util.JAXBContextResolverOSGI, could not be
> instantiated. Processing will continue but the class will not be utilized
> Throwable occurred: java.lang.RuntimeException: NATURAL JSON notation
> configured, but JAXB RI 2.1.10 not found. For the recent builds to get this
> working correctly, you need even at least JAXB version 2.1.12. Please add it
> to your classpath!
>        at
> com.sun.jersey.api.json.JSONConfiguration.natural(JSONConfiguration.java:378)
>        at
> org.apache.camel.web.util.JAXBContextResolverOSGI.(JAXBContextResolverOSGI.java:39)
>        at java.lang.J9VMInternals.newInstanceImpl(Native Method)
>        at java.lang.Class.newInstance(Class.java:1325)

This is an error from the Camel web app's use of the Jersey API. The
Camel web app is configured by default in the activemq.xml. If you are
not using Camel, just comment out the import of the camel.xml file in
the activemq.xml file.

The error indicates that some JAXB dependencies are missing from the
classpath. The com.sun.jersey.api.json.JSONJAXBContext class is used
for RESTful web services by the camel-web component. If you put the
appropriate JAXB 2.1.10 JARs on the classpath this error should go
away.

Bruce
-- 
perl -e 'print unpack("u30","D0G)U8V4\@4VYY9&5R\"F)R=6-E+G-N>61E<D\!G;6%I;\"YC;VT*"
);'

ActiveMQ in Action: http://bit.ly/2je6cQ
Blog: http://bruceblog.org/
Twitter: http://twitter.com/brucesnyder

Mime
View raw message