activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruce Snyder <bruce.sny...@gmail.com>
Subject Re: activemq 5.3.1 SEVERE: NATURAL JSON notation configured, but JAXB RI 2.1.10 not found.
Date Wed, 05 May 2010 22:31:24 GMT
On Wed, May 5, 2010 at 4:07 PM, Davis, Dorothea
<Dorothea_Davis@homedepot.com> wrote:
> I will be using camel routes, so I will need the correct jars.  How can I be sure I
get the correct one?

The errors are due to to the use of the Camel web console by default
in the ActiveMQ configuration. The Camel web console is not required
in order to use Camel routes.

According to the camel-web component's Maven POM, you need the
jaxb-api and the jaxb-impl. The versions vary depending on the version
of Camel you are using. Below are just a few:

Camel 2.2:
* jaxb-impl 2.1.12
* jaxb-api 2.1

Camel 2.1:
* jaxb-impl 2.1.12
* jaxb-api 2.1

Camel 2.0:
* jaxb-impl 2.1.10
* jaxb-api 2.1

Camel 1.6.2:
* jaxb-impl 2.1.6
* jaxb-api 2.1

Bruce
-- 
perl -e 'print unpack("u30","D0G)U8V4\@4VYY9&5R\"F)R=6-E+G-N>61E<D\!G;6%I;\"YC;VT*"
);'

ActiveMQ in Action: http://bit.ly/2je6cQ
Blog: http://bruceblog.org/
Twitter: http://twitter.com/brucesnyder

Mime
View raw message