activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: Active Consumers on TCP x HTTP
Date Mon, 17 May 2010 13:23:14 GMT
Hi,

can you raise a Jira (with possibly a test case that demonstrates the
issue)? It would help in investigating the problem.

Cheers
--
Dejan Bosanac - http://twitter.com/dejanb

Open Source Integration - http://fusesource.com/
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Mon, May 17, 2010 at 2:59 PM, jfaerman <jfaerman@gmail.com> wrote:

>
> Unfortunaly no, i had quit ActiveMQ and use HTTP pooling (that really sux).
> I think this must be an issue of the protocol.
> If you find a solution using *MQ please post :)
>
>
> simonmcc wrote:
> >
> >
> >
> > jfaerman wrote:
> >>
> >> Hello,
> >>
> >> I need a queue with HTTP consumers.
> >> My problem is that when the JVM dies, the consumer remains active (i can
> >> see them active in the web console), thus preventing the new consumer
> >> from receiving messages.
> >> If i use TCP instead of HTTP, the dead consumers are inactivated
> >> correctly and everything works.
> >>
> >> Anyone been thru something like this or can suggest me a workaround?
> >>
> >> Tnx,
> >> Julio
> >>
> >
> > Did you ever find a solution to this problem? I am seeing a very similar
> > issue now.
> >
> >
>
> --
> View this message in context:
> http://old.nabble.com/Active-Consumers-on-TCP-x-HTTP-tp26513355p28583022.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message