activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruce Snyder <bruce.sny...@gmail.com>
Subject Re: Messages appear in asynchronous queue one hour after send it
Date Thu, 22 Apr 2010 14:18:57 GMT
On Thu, Apr 22, 2010 at 7:24 AM, Robert Jacolin
<rjacolin@sierrawireless.com> wrote:
>
> Hello all,
>
> I'm using activemq 5.3.1 in an application with several queues and 2
> asynchronous queue for 3 servlets.
>
> Currently, I have a very big bug which break my application. My application
> work well many time but sometimes when I send messages to an async queue,
> the messages appear in the queue (I can see this on the activemq jetty
> console) after a long time (currently, 1 hour !), little by little, not in
> the sent order.
>
> When I restart activemq, all the messages appear in one time.
>
> I'm totally lost with this behaviour and I don't understand where our code
> is bad.
>
> Can you help me ?
>

If you want messages to be delivered in the order that they were sent
to the broker, then you need to configure the broker for this using
total ordering:

http://activemq.apache.org/total-ordering.html

As for your problem sending messages, I suggest that you walk through
the examples to understand how they work before doing anything else.
Information on the examples is available here:

http://activemq.apache.org/examples.html

If you are still having trouble, please provide code samples that you
are using to send messages so that we can take a look at them.

Bruce
-- 
perl -e 'print unpack("u30","D0G)U8V4\@4VYY9&5R\"F)R=6-E+G-N>61E<D\!G;6%I;\"YC;VT*"
);'

ActiveMQ in Action: http://bit.ly/2je6cQ
Blog: http://bruceblog.org/
Twitter: http://twitter.com/brucesnyder

Mime
View raw message