activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: https
Date Tue, 13 Apr 2010 08:40:57 GMT
Hi,

this is not yet implemented. We should probably introduce needClientAuth
parameter as we have for SSL transport
http://activemq.apache.org/how-do-i-use-ssl.html.

Can you raise Jira enhancement request for this?

Cheers
--
Dejan Bosanac - http://twitter.com/dejanb

Open Source Integration - http://fusesource.com/
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Mon, Apr 12, 2010 at 7:46 PM, Mike Rawlins <mcr@mcrawlins.net> wrote:

>
> I don't know what the original submitter was trying to do, but I have a
> question and it seems as if I might have the same problem.
>
> The HTTPS configuration for the broker seems to enable the client to
> validate the identity of the broker and encrypt the connection. However,
> this may not be enough for my use case.  I would also like to have the
> broker validate https connections from clients, and this doesn't seem to
> work.  I can connect to the broker from a client without importing the
> client's certificate into the broker's truststore.  The connection comes up
> OK, the client is able to send messages to the broker, and I get no errors.
> As you note, the needClientAuth option for HTTPS seems to be ignored.
>
> Is the functionality I'm looking for not implemented yet, or is it not
> there
> by design? If it's not there by design, is there another way to accomplish
> what I would like to do?
>
> Thanks,
>
> Mike
>
>
> Dejan Bosanac wrote:
> >
> > Hi,
> >
> > what exactly are you trying to achieve and what error are you getting?
> >
> >
>
> --
> View this message in context:
> http://old.nabble.com/https-tp27563446p28219167.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message