activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: ActiveMQ AJAX Problems
Date Fri, 23 Apr 2010 08:35:00 GMT
Hi,

it looks to me that you're trying to access the server on another host. Bear
in mind that Ajax employs same-origin policy and that you need to use some
kind of cross-domain mechanism to make it work.

Cheers
--
Dejan Bosanac - http://twitter.com/dejanb

Open Source Integration - http://fusesource.com/
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Thu, Apr 22, 2010 at 5:51 PM, magellings <mark.gellings@qg.com> wrote:

>
> <script type="text/javascript"
> src="http://sxdevweb1.qg.com:8099/shared/cache/jquery/142/jquery-1.4.2.js
> "></script>
> <script type="text/javascript"
> src="
> http://sxdevweb1.qg.com:8099/shared/cache/jquery-ui/172/jquery-ui-1.7.2.js
> "></script>
>  <script type="text/javascript"
> src="/scripts/amq_jquery_adapter.js"></script>
>    <script type="text/javascript" src="/scripts/amq.js"></script>
>    <script type="text/javascript">
>        amq = org.activemq.Amq;
>        amq.init({ uri: 'http://wamqdev1:10200/admin/ajax', logging: true
> });
>        amq.sendMessage("topic://t1", "message");
> //        amq.addListener("test", "topic://t1", function (message) {
> //            alert("hi");
> //        });
>    </script>
>
> I don't get the error mentioned in this thread with this script however.  I
> don't see any http activity when doing a network trace between my machine
> and the ActiveMQ host (wamqdev1).  This is why I switched to using Fiddler2
> to try and troubleshoot the problem (as my original post on this thread
> mentioned).  That is when I got the exception reported in this thread.
>
> We are using jquery 1.4.2 as you can see, and here's the
> http://old.nabble.com/file/p28330842/amq.js amq.js  and
> http://old.nabble.com/file/p28330842/amq_jquery_adapter.js
> amq_jquery_adapter.js  files we are using, which should be the same as from
> issue AMQ-1377.
>
>
>
> Dejan Bosanac wrote:
> >
> > Hi,
> >
> > can you post your JavaScript code that is not working for you?
> >
> > Cheers
> > --
> > Dejan Bosanac - http://twitter.com/dejanb
> >
> > Open Source Integration - http://fusesource.com/
> > ActiveMQ in Action - http://www.manning.com/snyder/
> > Blog - http://www.nighttale.net
> >
> >
>
> --
> View this message in context:
> http://old.nabble.com/ActiveMQ-AJAX-Problems-tp28287864p28330842.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message