activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Martin C." <mart...@gmx.at>
Subject Re: XA and setMessageListener()?
Date Tue, 27 Apr 2010 06:12:06 GMT

Hi,

thanks for your reply.


Gary Tully wrote:
> 
> There needs to be some JTA wrapper on the activemq session that will start
> a
> transaction and enlist the activemq XAResource for you. For Atomikos I
> think
> it is something like:
> 
>     <bean id="atomikosConnectionFactory"
> class="com.atomikos.jms.AtomikosConnectionFactoryBean"
>         init-method="init" destroy-method="close">
>         <property name="uniqueResourceName" value="activemq" />
>         <property name="xaConnectionFactory" ref="xaFactory" />
>     </bean>
> 
> 
> Can you post a simple test case or your config if that is not the problem?
> 

Basically, this is my setup. The problem seems to be that no transaction is
started in the ActiveMQ message dispatcher. I will try to provide a minimal
example in the evening, as I cannot hand out the code I am using here (quite
strict policy at my company).

At the moment, I am using a Spring JmsTemplate approach. The Spring
JmsTemplates work with polling (i.e. blocking call on receive()) and sets up
the transaction before. This works fine.

Again, one important information (I missed to mention, sorry), is that I am
still on 5.3.0.

Best regards,
Martin
-- 
View this message in context: http://old.nabble.com/XA-and-setMessageListener%28%29--tp28355420p28373226.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message