activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Waterinius <ada...@dgt.com.pl>
Subject Caught exception sending shutdown
Date Wed, 14 Apr 2010 17:24:25 GMT

Hi,
I've 2 brokers working in failover on two different machines under Centos
5.3

Here is configuration one of them.

<beans
  xmlns="http://www.springframework.org/schema/beans"
  xmlns:amq="http://activemq.apache.org/schema/core"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
  http://activemq.apache.org/schema/core
http://activemq.apache.org/schema/core/activemq-core.xsd">

    <!-- Allows us to use system properties as variables in this
configuration file -->
    <bean
class="org.springframework.beans.factory.config.PropertyPlaceholderConfigurer">
        <property name="locations">
            <value>file:${activemq.base}/conf/credentials.properties</value>
        </property>              
    </bean>

    <broker xmlns="http://activemq.apache.org/schema/core"
brokerName="localhost62" dataDirectory="${activemq.base}/data"
persistent="true" useShutdownHook="false">

        <managementContext>
            <managementContext createConnector="true"/>
        </managementContext>
 	<networkConnectors>
            <networkConnector name="wire_to_50"
uri="static://(tcp://192.170.8.62:61616)"/>
        </networkConnectors>        
        <persistenceAdapter>
            <kahaDB directory="${activemq.base}/data/kahad"
enableJournalDiskSyncs="false" indexWriteBatchSize="10000"
indexCacheSize="1000"  journalMaxFileLength="50mb" cleanupInterval="20000"
checkpointInterval="10000" />
        </persistenceAdapter>
        
        
        
              
        <destinationPolicy>
            <policyMap>
              <policyEntries>
                <policyEntry topic=">" producerFlowControl="false"
memoryLimit="150mb">
                  <pendingSubscriberPolicy>
                    <vmCursor />
                  </pendingSubscriberPolicy>
                </policyEntry>
                <policyEntry queue=">" producerFlowControl="false"
memoryLimit="150mb">      
                </policyEntry>
              </policyEntries>
            </policyMap>
        </destinationPolicy> 
       
        <transportConnectors>
            <transportConnector name="openwire" uri="tcp://0.0.0.0:61616"/>
        </transportConnectors>

    </broker>
    <import resource="jetty.xml"/>    
</beans>


>From time to time this error occur and shutting down a worker.  


 | DEBUG | Caught exception sending shutdown |
org.apache.activemq.network.DemandForwardingBridge | NetworkBridge
org.apache.activemq.transport.InactivityIOException: Channel was inactive
for too long: /192.170.8.50:61616
	at
org.apache.activemq.transport.InactivityMonitor.oneway(InactivityMonitor.java:229)
	at
org.apache.activemq.transport.TransportFilter.oneway(TransportFilter.java:83)
	at
org.apache.activemq.transport.WireFormatNegotiator.oneway(WireFormatNegotiator.java:104)
	at
org.apache.activemq.transport.MutexTransport.oneway(MutexTransport.java:40)
	at
org.apache.activemq.transport.ResponseCorrelator.oneway(ResponseCorrelator.java:60)
	at
org.apache.activemq.network.DemandForwardingBridgeSupport$5.run(DemandForwardingBridgeSupport.java:371)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)


this error occurs earlier

 | DEBUG | Transport failed:
org.apache.activemq.transport.InactivityIOException: Channel was inactive
for too long: /192.170.8.50:33398 |
org.apache.activemq.broker.TransportConnection.Transport | InactivityMonitor
Async Task: java.util.concurrent.ThreadPoolExecutor$Worker@f09d3d
org.apache.activemq.transport.InactivityIOException: Channel was inactive
for too long: /192.170.8.50:33398
	at
org.apache.activemq.transport.InactivityMonitor$4.run(InactivityMonitor.java:168)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)


Please, help. Is error in configuration or what? 


-- 
View this message in context: http://old.nabble.com/Caught-exception-sending-shutdown-tp28245666p28245666.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message