activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruce Snyder <bruce.sny...@gmail.com>
Subject Re: updating from 5.3.0 -> 5.3.1 now the admin console's not working
Date Wed, 31 Mar 2010 00:05:39 GMT
On Tue, Mar 30, 2010 at 11:17 PM, Bruce Snyder <bruce.snyder@gmail.com> wrote:
> On Tue, Mar 30, 2010 at 10:52 PM, foucault <aric@status.net> wrote:
>>
>>
>>> so in short, as of updating to 5.3.1 the admin console never shows up,
>>> netstat doesn't show anything running on port 8161, although the logs tell
>>> me it has been launched.  anyone else encounter this problem?
>>
>> I just double-checked this with the 5.3.1 binary tarball from the
>> release and the admin console is working just fine. If you download a
>> fresh binary, expand it and run it without modifying the activemq.xml,
>> does the admin console work for you?
> ...
>
>> Indeed, it works as expected.
>> fiddling around between the base config and my own I think I have narrowed
>> it down.
>>
>> this works in 5.3.0
>>      <transportConnector name="stomp" uri="stomp://10.1.200.30:61613"/>
>> but in 5.3.1 it only works like this
>>      <transportConnector name="stomp" uri="stomp://0.0.0.0:61613"/>
>> If i start it in 5.3.1 with the proper bind address (10.1.200.30), Something
>> gets stuck. I can only kill the java process with kill -9, but... the
>> program works, just without the admin interface.
>>
>> we are currently using 5.3.0 without issue.
>
> You are correct, this seems to be a bug in 5.3.1. When I enable debug
> level logging, I see the following statement over and over:
>
> DEBUG | Connect fail to: tcp://localhost:61616, reason:
> java.net.ConnectException: Connection refused
>
> Notice the use of localhost.
>
> What does your /etc/hosts file look like?

Nevermind looking at your /etc/hosts file, it's got nothing to do with that.

The problem is in the Camel web app that is loaded in the
conf/jetty.xml file. Just comment it out and the ActiveMQ admin
console will start up correctly.

Bruce
-- 
perl -e 'print unpack("u30","D0G)U8V4\@4VYY9&5R\"F)R=6-E+G-N>61E<D\!G;6%I;\"YC;VT*"
);'

ActiveMQ in Action: http://bit.ly/2je6cQ
Blog: http://bruceblog.org/
Twitter: http://twitter.com/brucesnyder

Mime
View raw message