activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: ActiveMQ doesn't close connections
Date Mon, 08 Mar 2010 09:18:27 GMT
Hi,

it seems like you're closing all that is there to close, but maybe missing
to close it in some situations. There isn't much we can do, until we have a
reproducible "test case", so if you can just strip down your app only on
messaging related part and that, it would be great.

Cheers
--
Dejan Bosanac - http://twitter.com/dejanb

Open Source Integration - http://fusesource.com/
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Thu, Mar 4, 2010 at 8:23 PM, freders <federico@linuxspot.com.ar> wrote:

>
> Hi Dejan,
>
> I'll post the problem on Jira, but I don't have any test case. The web
> application is really big, so I don't think I'm able to create one.
>
> Could you give some hints about what I should close on the message consumer
> side? Or should I close also something in the message listener part?
>
> Regards,
>
>
>
> Dejan Bosanac wrote:
> >
> > Hi,
> >
> > we didn't here about this problem before. Can you raise a Jira for it,
> and
> > preferably provide a test case?
> >
> > Cheers
> > --
> > Dejan Bosanac - http://twitter.com/dejanb
> >
> > Open Source Integration - http://fusesource.com/
> > ActiveMQ in Action - http://www.manning.com/snyder/
> > Blog - http://www.nighttale.net
> >
> >
> > On Thu, Mar 4, 2010 at 5:18 PM, freders <federico@linuxspot.com.ar>
> wrote:
> >
> >>
> >> Hello to everyone,
> >>
> >> I'm using Apache 2, Tomcat 6 and ActiveMQ 5.2.0. I'm using request-reply
> >> messages mode. ActiveMQ works well except that it doesn't close the
> >> ESTABLISHED connections. So, after a couple of hours running, there are
> >> not
> >> available file descriptors left to accept new connections due to
> ActiveMQ
> >> doesn't close them.
> >>
> >> After an object sends a message to other application, some resources are
> >> released like in this piece of code:
> >>
> >>            session.close();
> >>            tmpQueue.delete();
> >>            connection.close();
> >>            responseConsumer.close();
> >>            producer.close();
> >>
> >> The info gathered by the command 'netstat -natp | grep ESTABLISHED |
> grep
> >> :61617' (ssl connector) shows me the number of established connections,
> >> which is huge after a couple of hours.
> >>
> >> ¿Have anyone had a problem like this? If so, ¿how was it solved?
> >>
> >> Thanks in advance,
> >>
> >> --
> >> View this message in context:
> >>
> http://old.nabble.com/ActiveMQ-doesn%27t-close-connections-tp27783008p27783008.html
> >> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
> >>
> >>
> >
> >
> > -----
> > Dejan Bosanac
> >
> > Open Source Integration - http://fusesource.com/
> > ActiveMQ in Action - http://www.manning.com/snyder/
> > Blog - http://www.nighttale.net
> >
>
> --
> View this message in context:
> http://old.nabble.com/ActiveMQ-doesn%27t-close-connections-tp27783008p27785372.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message