activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jumbro <jum...@fortress.com>
Subject AMQ persistence not working for me
Date Wed, 17 Mar 2010 20:52:54 GMT

Hello,

I have been trying to get persistence working and have been humbled by the
experience.


Here is my setup:

•	AMQ 5.3
•	Monitoring via AMQ web console deployed in jetty
•	Using Spring.NET 1.2 / Apache.NMS
•	Tried each of the available AMQ persistence schemes (see attached
activemq.xml)
•	Set both NmsTemplate.Persistent = true and
Apache.NMS.Message.NMSPersistent = true on the producer
•	My preference is to use  journaledJDBCAdaptor against Sql Server 2008

Test performed:

•	start AMQ
•	start my message producer (creates dynamic topic by default)
•	observe messages enqueued to topic via web console
•	stop and start AMQ

Here are the issues I'm having (consider journaledJDBC case):

1) I first noticed that nothing appears to be getting written to my journal
2) When restarting AMQ, the output tells me (when starting the journal
persistence adapter): "Journal Recovered: 0 message(s) in transactions
recovered"
3) When AMQ restarts, the topic and messages have been deleted

I did do some tests (days/weeks ago) where I saw some messages being logged
to Sql Server. But at no time did I have a successful test of recycling AMQ
and seeing the existing queue/topic with pending messages populated.

Live message production/consumption works great for me, both pub/sub and
request reply. I just can't get persistence working. Please help!

http://old.nabble.com/file/p27937801/activemq.xml activemq.xml  attached.

thanks in advance.
jonah




-- 
View this message in context: http://old.nabble.com/AMQ-persistence-not-working-for-me-tp27937801p27937801.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message