activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lucious <marcin.gi...@arise.pl>
Subject ActiveMQ 12.03.2010 snapshot + CMS -> memory limit reached on temp-queue and topic
Date Tue, 16 Mar 2010 20:56:17 GMT

Hello again,,

I tried and gave a goal with this snapshot and new configuration file -
removed vmCursors for Store/File:

    <broker xmlns="http://activemq.apache.org/schema/core"
brokerName="localhost" useJmx="true" dataDirectory="${activemq.base}/data"
destroyApplicationContextOnStop="true">
 
        <destinationPolicy>
            <policyMap>
              <policyEntries>
                <policyEntry topic=">" producerFlowControl="false"
memoryLimit="100mb">
                  <dispatchPolicy>
                        <strictOrderDispatchPolicy />
                  </dispatchPolicy>
                </policyEntry>
                <policyEntry queue=">" producerFlowControl="false"
memoryLimit="100mb">
                  <dispatchPolicy>
                        <strictOrderDispatchPolicy />
                  </dispatchPolicy>
                  <pendingQueuePolicy>
                        <fileQueueCursor/>
                  </pendingQueuePolicy>
                </policyEntry>
              </policyEntries>
            </policyMap>
        </destinationPolicy>
              
        <managementContext>
            <managementContext createConnector="false"/>
        </managementContext>

        <persistenceAdapter>
            <kahaDB directory="${activemq.base}/data/kahadb"
enableJournalDiskSyncs="false" indexWriteBatchSize="10000"
indexCacheSize="1000" />
        </persistenceAdapter>

        <systemUsage>
            <systemUsage>
                <memoryUsage>
                    <memoryUsage limit="512 mb"/>
                </memoryUsage>
                <storeUsage>
                    <storeUsage limit="15 gb" name="store"/>
                </storeUsage>
                <tempUsage>
                    <tempUsage limit="10 gb"/>
                </tempUsage>
            </systemUsage>
        </systemUsage>
        <transportConnectors>
            <transportConnector name="openwire"
uri="tcp://0.0.0.0:61616?wireFormat.maxInactivityDuration=0"/>
        </transportConnectors>
    </broker>
    <import resource="jetty.xml"/>
    
</beans>

but then again I faced memory limit. 

2010-03-16 15:02:28,455 | INFO  | Usage Manager Memory Limit reached on
temp-queue://e0499daa-604e-227c-57c5-8a700a83d690:0. Producers will be
throttled to the rate at which messages are removed from this destination to
prevent flooding it. See
http://activemq.apache.org/producer-flow-control.html for more info |
org.apache.activemq.broker.region.Queue | ActiveMQ Transport:
tcp:///127.0.0.1:46737
2010-03-16 15:02:28,582 | INFO  | Usage Manager memory limit (536870912)
reached for temp-topic://47441d3c-6561-36a7-9904-11f5a2404d8f:0. Producers
will be throttled to the rate at which messages are removed from this
destination to prevent flooding it. See
http://activemq.apache.org/producer-flow-control.html for more info |
org.apache.activemq.broker.region.Topic | ActiveMQ Transport:
tcp:///127.0.0.1:44605

why is this happening? If I understand right when 70% of memory is reached
(in my case 512MB limit) all messages should go to the file? But it seems
like AMQ takes all memory until it;s exhausted and then hangs all consumers.
The only solution for this is to restart AMQ.

Maybe my configuration is still wrong, but according to information from
this forum and docs from amq I can't find any solution for this. 

PLease advice,
thx
M.
-- 
View this message in context: http://old.nabble.com/ActiveMQ-12.03.2010-snapshot-%2B-CMS--%3E-memory-limit-reached-on-temp-queue-and-topic-tp27924410p27924410.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message