activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank Werner <activ...@wesoft.de>
Subject Re: Issue in example with failover
Date Tue, 09 Mar 2010 09:20:37 GMT

Hi Dejan,

thanks for your reply. In fact, your example works ... unfortunately just
until one server fails :-(

If I stop the server the example is connected to, I got the following
output:

root@broker1:/opt/apache-activemq-5.3.0/example # ant topic-listener
-Durl='failover://(tcp://broker1:62828,tcp://broker2:62828)'
Buildfile: build.xml

init:

compile:

topic-listener:
     [java] 10:12:27 INFO  Successfully connected to tcp://broker2:62828
     [java] Waiting for messages...
     [java] Java Result: 143

BUILD SUCCESSFUL
Total time: 21 seconds
root@broker1:/opt/apache-activemq-5.3.0/example #

What am I doing wrong?

-Frank-


Dejan Bosanac wrote:
> 
> Hi Frank,
> 
> nio is a server-side protocol, so you shouldn't be using it in client
> URL's
> 
> try using -Durl="failover://(tcp://broker1:62828,tcp://broker2:62828)"
> 
> at least it worked when I tested it.
> 
> Cheers
> --
> Dejan Bosanac - http://twitter.com/dejanb
> 
> Open Source Integration - http://fusesource.com/
> ActiveMQ in Action - http://www.manning.com/snyder/
> Blog - http://www.nighttale.net
> 
> 
> On Mon, Mar 8, 2010 at 6:13 PM, Frank Werner <activemq@wesoft.de> wrote:
> 
>>
>> Hello world,
>>
>> I tried out the topic listener example delivered with active mq 5.3.
>> Without failover, it works very well and waits for incoming messages.
>> With failover, it stops working after 11 seconds, when no messages
>> arrives.
>> The same problems occurs with failover with only one broker or with tcp
>> transport protocol.
>>
>> Look here:
>> ----------
>>
>> root@broker1:/opt/apache-activemq-5.3.0/example # ant topic-listener
>> -Durl="failover://(nio://broker1:62828,nio://broker2:62828)"
>> Buildfile: build.xml
>>
>> init:
>>
>> compile:
>>
>> topic-listener:
>>     [java] 18:05:40 INFO  Successfully connected to nio://broker1:62828
>>     [java] Waiting for messages...
>>
>> BUILD SUCCESSFUL
>> Total time: 11 seconds
>> root@broker1:/opt/apache-activemq-5.3.0/example #
>>
>> I think it has something to do with the InactivityMonitor?
>>
>> Is there somebody who uses the failover scenario?
>>
>> Thanks in advance,
>> -Frank-
>> --
>> View this message in context:
>> http://old.nabble.com/Issue-in-example-with-failover-tp27824427p27824427.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>>
> 
> 
> -----
> Dejan Bosanac
> 
> Open Source Integration - http://fusesource.com/
> ActiveMQ in Action - http://www.manning.com/snyder/
> Blog - http://www.nighttale.net
> 

-- 
View this message in context: http://old.nabble.com/Issue-in-example-with-failover-tp27824427p27833193.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message