activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cmoulliard <cmoulli...@gmail.com>
Subject ActiveMq Master/Slave & ServiceMix 4
Date Thu, 04 Mar 2010 16:35:02 GMT

Hi,

I have created a Master/Slave configuration of ActiveMq through 2
instances of ServiceMix 4 (so ActiveMq is in embedded mode) running on
the same host. The 2 instances of activemq have been deployed
successfully and run well. The two instances are configured to use the
same persistence adapter :

      <persistenceAdapter>
           <amqPersistenceAdapter syncOnWrite="false"
directory="d:/temp/activemq/default" maxFileLength="20 mb"/>
       </persistenceAdapter>

I have created a queue (IN) and a message on the Master activeMq. If I
shutdown the Master activemq server, I see that the slave who was
sleeping wake up BUT
if I look (using jconsole) to the activemq config of the slave, I
don't see the queue IN + message posted and not consumed.

Is it normal or an issue  ?

Additional remark : If I shutdown the SMX4 server (master) and restart it,
then the message + queue have been lost. Very strange isn't it !!!!

Kind regards,

Charles Moulliard
Senior Enterprise Architect
Apache Camel Committer

*****************************
blog : http://cmoulliard.blogspot.com
twitter : http://twitter.com/cmoulliard
Linkedlin : http://www.linkedin.com/in/charlesmoulliard

Apache Camel Group :
http://www.linkedin.com/groups?home=&gid=2447439&trk=anet_ug_hm

-----
Charles Moulliard
SOA Architect

My Blog :  http://cmoulliard.blogspot.com/ http://cmoulliard.blogspot.com/  
-- 
View this message in context: http://old.nabble.com/ActiveMq-Master-Slave---ServiceMix-4-tp27783221p27783221.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message