activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jonasbergstrom <jonas.bergst...@bwin.org>
Subject Re: Connecting to Tibco RV from ActiveMQ
Date Wed, 03 Mar 2010 13:13:11 GMT


bsnyder wrote:
> 
> There is no built-in support for integrating with RV built in to
> ActiveMQ, but it can bridge to TIBCO EMS. Here's an example:
> 
> http://activemq.apache.org/jms-bridge-with-remote-tibco-broker.html
> 
That example works well except for initial connection (when Tibco is down,
where the creation of the ActiveMQ broker actually hangs) and reconnecting
to Tibco after network problems. I've configured Tibco's connection factory
with it's proprietary connect/reconnect properties like:
    <bean id="tibco" class="com.tibco.tibjms.TibjmsQueueConnectionFactory">
        <property name="serverUrl" value="tcp://localhost:7222"/>
        <property name="connAttemptCount" value="10"/>
        <property name="connAttemptDelay" value="6000"/>
        <property name="connAttemptTimeout" value="60"/>
        <property name="reconnAttemptCount" value="10"/>
        <property name="reconnAttemptDelay" value="6000"/>
        <property name="reconnAttemptTimeout" value="60"/>
    </bean> 
...but they don't "bite". I'e if I restart Tibco, the bridge between
ActiveMQ and Tibco don't reconnect. 
Do you know where I should look further to get this working, on the ActiveMQ
side or in the Tibco client?

Thnx / Jonas
-- 
View this message in context: http://old.nabble.com/Connecting-to-Tibco-RV-from-ActiveMQ-tp26111003p27768014.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message