activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pavel <pag...@gmail.com>
Subject Re: Stuck messages - Dispatch issues
Date Sat, 20 Feb 2010 16:02:22 GMT
Sounds scary to me, as system I'm working on uses activemq extensively, and
is not production-proven yet.

Do you have/can you build a junit test case that reproduces the issue under
5.3? If so, that looks like a good start for Jira defect.

Disclaimer - I'm not an AMQ committer.

Thanks,
Pavel

On Sat, Feb 20, 2010 at 9:23 AM, Elliot Barlas <elliotbarlas@gmail.com>wrote:

>
> Unfortunately I am seeing it in 5.3.  I just posted on this more current
> thread as well:
>
> http://old.nabble.com/50k-%2B-messages-stuck-in-queue-with-all-consumers-blocking-on-receive-td27162095.html
>
> Thanks,
> Elliot
>
>
>
> rajdavies wrote:
> >
> > This should be resolved in 5.3
> > On 20 Feb 2010, at 07:12, Elliot Barlas wrote:
> >
> >>
> >> Was this issue ever resolved?  I am seeing this as well with a large
> >> number
> >> of concurrent consumers.  Same symptoms.  Lost messages until broker
> >> restart.
> >>
> >> Thanks,
> >> Elliot
> >>
> >>
> >>
> >> chrajanirao wrote:
> >>>
> >>> We are seeing issues with ActiveMQ 5.1 and 5.2 RC2 with message
> >>> dispatching from queues. It is easily reproducible even using the
> >>> out of
> >>> the box activemq configuration.
> >>>
> >>> Send messages to the a queue (QueueA) using multiple threads (10 or
> >>> 20
> >>> thread in a loop of 10) using JMeter or your custom code. Have the
> >>> consumer setup using spring DMLC (DefaultMessageListenerContainer)
> >>> or with
> >>> regular JMS API sync or async consumption with multiple consumers.
> >>> Consumer part can be configured using Camel to consumer from QueueA
> >>> and
> >>> put the messages in QueueB within ActiveMQ configuration as well.
> >>>
> >>> After receiving some messages (the number is different each time),
> >>> the
> >>> consumers stop receiving any messages even though there are some
> >>> left on
> >>> the queue. Basically, the broker don't dispatch the messages  and
> >>> they are
> >>> stuck until restart of the broker. Any new messages sent to the queue
> >>> after this are sometimes dispatched and other times they are stuck
> >>> too.
> >>>
> >>> This certainly seems like a major bug in the dispatch mechanism. I
> >>> have
> >>> found below posts that state the exact problem.
> >>>
> >>>
> http://www.nabble.com/Pending-Messages-are-shown-in-ActiveMQ-td20241332.html
> >>>
> >>>
> http://www.nabble.com/Consumer-Listener-stop-receving-message-until-ActiveMQ-restart-td20355247.html
> >>>
> >>> This is a very basic use case and I wonder how the version 5.1 is
> >>> currently used in production, if anyone is using at all.
> >>>
> >>> We tried with prefetch limit as 1, asyncDispatch as true and false,
> >>> session transacted as true and false. In all cases, the dispatch
> >>> problem
> >>> still exists starting after 100 messages until 1000 messages.
> >>>
> >>> I hope any of the active commiters looks into this issue seriously.
> >>> Would
> >>> really appreciate the help.
> >>>
> >>> Thanks,
> >>> Rajani.
> >>>
> >>
> >> --
> >> View this message in context:
> >>
> http://old.nabble.com/Stuck-messages---Dispatch-issues-tp20467949p27664135.html
> >> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
> >>
> >
> > Rob Davies
> > http://twitter.com/rajdavies
> > I work here: http://fusesource.com
> > My Blog: http://rajdavies.blogspot.com/
> > I'm writing this: http://www.manning.com/snyder/
> >
> >
> >
> >
> >
> >
> >
>
> --
> View this message in context:
> http://old.nabble.com/Stuck-messages---Dispatch-issues-tp20467949p27664182.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message