activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: response never delivered using JMSCorrelationId
Date Fri, 05 Feb 2010 08:55:45 GMT
can you post the configuration of the brokers? sounds like you need a duplex
networkconnector or a networkconnector (as they are one way by default)
configured on each broker.
see:
http://activemq.apache.org/networks-of-brokers.html#NetworksofBrokers-NetworkConnectorProperties


On 5 February 2010 01:27, samp <sam@brightcove.com> wrote:

>
> I'm using spring integrations JmsOutboundGateway. I believe the problem I'm
> seeing is a configuration issue with ActiveMQ which is why I am posting the
> question here.
>
> I have 2 brokers (call them A and B) in a network each with a couple
> clients
> connected to them. I am getting into a situation where a response destined
> for a client connected to Broker A never reaches the consumer that is
> sitting on Broker B. I use jmx to browse the queue on Broker A and I see
> the
> message with a JMSCorrelationId.  I can also see in jmx that there is a
> queue subscriber waiting on Broker B.
>
> It works just fine in revers. If the client connected to Broker B sends the
> message, there is no problem. The message is delivered and everything is
> fine.
>
> I'm look for suggestions on how to debug this problem.
>
> thanks
> sam
> --
> View this message in context:
> http://old.nabble.com/response-never-delivered-using-JMSCorrelationId-tp27462376p27462376.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>


-- 
http://blog.garytully.com

Open Source Integration
http://fusesource.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message