activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: activemq-admin stop does not work
Date Tue, 16 Feb 2010 15:54:14 GMT
Hi,

Both 5.3.1 and 5.4 snapshots should contain same changes

https://repository.apache.org/content/repositories/snapshots/org/apache/activemq/apache-activemq/

Cheers
--
Dejan Bosanac - http://twitter.com/dejanb

Open Source Integration - http://fusesource.com/
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Tue, Feb 16, 2010 at 4:40 PM, wrfeldmann <work@rf-consulting.com> wrote:

>
> The snapshot of 5.3.0 or 5.3.1?
>
>
> Dejan Bosanac wrote:
> >
> > There has been some work in that area after 5.3.0 release. Can you try
> > latest snapshot and see if the problem is still there?
> >
> > Cheers
> > --
> > Dejan Bosanac - http://twitter.com/dejanb
> >
> > Open Source Integration - http://fusesource.com/
> > ActiveMQ in Action - http://www.manning.com/snyder/
> > Blog - http://www.nighttale.net
> >
> >
> > On Tue, Feb 16, 2010 at 4:07 PM, wrfeldmann <work@rf-consulting.com>
> > wrote:
> >
> >>
> >> I've searched both forums and have found nothing specific to the problem
> >> I'm
> >> having.  I'm using activemq 5.3.0 with 2 servers running.  I've enabled
> >> all
> >> of the jmx components in the activemq.xml file
> >>
> >>        <managementContext>
> >>            <managementContext
> >> connectorPath="service:jmx:rmi://${backside.server.name}:1099/jmxrmi"
> />
> >>        </managementContext>
> >>
> >> and in both the bin/activemq and bin/activemq-admin
> >>
> >> SUNJMX="-Dcom.sun.management.jmxremote.port=1099
> >> -Dcom.sun.management.jmxremote.authenticate=false
> >> -Dcom.sun.management.jmxremote.ssl=false"
> >>
> >> We have 2 activemq servers up and running.  The server that starts first
> >> will stop properly when activemq-admin stop is issued.  The server that
> >> was
> >> started second and is attempting to acquire the exclusive lock will not
> >> stop
> >> when the activemq-admin stop is issued.
> >>
> >> before stop:
> >>
> >>  /usr/java/jre1.6.0_17/bin/java -Xmx512M
> >> -Dorg.apache.activemq.UseDedicatedTaskRunner=true
> >> -Dcom.sun.management.snmp.port=1161
> >> -Dcom.sun.management.snmp.interface=acsamq00.int.brivo.net
> >> -Dcom.sun.management.snmp.acl.file=/home/jboss/brivo/snmp.acl
> >> -Dcom.sun.management.jmxremote.port=1099
> >> -Dcom.sun.management.jmxremote.authenticate=false
> >> -Dcom.sun.management.jmxremote.ssl=false
> >> -Dactivemq.classpath=/usr/local/messaging/messaging/conf;
> >> -Dactivemq.home=/usr/local/messaging/messaging
> >> -Dactivemq.base=/usr/local/messaging/messaging -jar
> >> /usr/local/messaging/messaging/bin/run.jar start
> >>
> >> actvemq-admin stop output:
> >>
> >> Java Runtime: Sun Microsystems Inc. 1.6.0_17 /usr/java/jre1.6.0_17
> >>  Heap sizes: current=7680k  free=7281k  max=506816k
> >>    JVM args: -Xmx512M -Dorg.apache.activemq.UseDedicatedTaskRunner=true
> >> -Dactivemq.classpath=/usr/local/messaging/messaging/conf;
> >> -Dactivemq.home=/usr/local/messaging/messaging
> >> -Dactivemq.base=/usr/local/messaging/messaging
> >> ACTIVEMQ_HOME: /usr/local/messaging/messaging
> >> ACTIVEMQ_BASE: /usr/local/messaging/messaging
> >> Connecting to JMX URL:
> >> service:jmx:rmi:///jndi/rmi://localhost:1099/jmxrmi
> >> INFO: There are no brokers to stop.
> >>
> >> after stop
> >>
> >> /usr/java/jre1.6.0_17/bin/java -Xmx512M
> >> -Dorg.apache.activemq.UseDedicatedTaskRunner=true
> >> -Dcom.sun.management.snmp.port=1161
> >> -Dcom.sun.management.snmp.interface=acsamq00.int.brivo.net
> >> -Dcom.sun.management.snmp.acl.file=/home/jboss/brivo/snmp.acl
> >> -Dcom.sun.management.jmxremote.port=1099
> >> -Dcom.sun.management.jmxremote.authenticate=false
> >> -Dcom.sun.management.jmxremote.ssl=false
> >> -Dactivemq.classpath=/usr/local/messaging/messaging/conf;
> >> -Dactivemq.home=/usr/local/messaging/messaging
> >> -Dactivemq.base=/usr/local/messaging/messaging -jar
> >> /usr/local/messaging/messaging/bin/run.jar start
> >>
> >> Thanks,
> >>
> >> Rick
> >> --
> >> View this message in context:
> >>
> http://old.nabble.com/activemq-admin-stop-does-not-work-tp27609710p27609710.html
> >> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
> >>
> >>
> >
> >
> > -----
> > Dejan Bosanac
> >
> > Open Source Integration - http://fusesource.com/
> > ActiveMQ in Action - http://www.manning.com/snyder/
> > Blog - http://www.nighttale.net
> >
>
> --
> View this message in context:
> http://old.nabble.com/activemq-admin-stop-does-not-work-tp27609710p27610213.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message