activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: trouble setting up webconsole on tomcat
Date Sun, 07 Feb 2010 12:12:03 GMT
Hi,

you don't need to use JNDI to set up the console. You can just use system
properties, like explained here

http://activemq.apache.org/web-console.html#WebConsole-ExampleconfigurationusingTomcat

Cheers
--
Dejan Bosanac - http://twitter.com/dejanb

Open Source Integration - http://fusesource.com/
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Sat, Feb 6, 2010 at 9:18 PM, bhomass <bhomass1@cox.net> wrote:

>
> I am using a standalone broker which runs fine off the bin distribution (on
> windows).
>
> I followed the instructions on http://activemq.apache.org/web-console.html
> .
> the only part I don't know what to do with are the lines
>
> # java:comp/env/jms/connectionFactory: JMS-ConnectionFactory (Type
> javax.jms.ConnectionFactory)
> # java:comp/env/jmx/url: URL of the brokers JMX (Type java.lang.String)
>
> under Configuring jdni. where do I make use of these jndi resource names?
> in
> one of the xml config files or what?
>
> I expanded the war file and created an eclipse project out of it. the
> activemq-all.jar is in the lib folder. and added in the system property
> settings.
>
> when I start the server, I get a
> nullpointerexception from
> org.aspectj.weaver.ResolvedType.lookupResolvedMember
>
> and when I pull up the webpage I get
>
> Error reading 'brokerName' on type
> org.apache.activemq.web.RemoteJMXBrokerFacade
>
>
> anyone recognizes these errors?
> --
> View this message in context:
> http://old.nabble.com/trouble-setting-up-webconsole-on-tomcat-tp27482949p27482949.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message