activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ActiveUser <cutebear...@hotmail.com>
Subject Re: AMQ hangs on FIN_WAIT
Date Sat, 20 Feb 2010 19:55:45 GMT

Currently we are not but have considered that. Our messaging layer will also
try reconnect. 

One of my concern is that the client does not detect disconnection properly.
So I want to see if there is anything else to fix before we use fail-over.
After all, one can only run one or two fail-over servers to be practical.


bsnyder wrote:
> 
> On Sat, Feb 20, 2010 at 12:03 PM, ActiveUser <cutebear103@hotmail.com>
> wrote:
>>
>> Hi,
>>
>> We have run into cases in which some clients hang and we have restart the
>> AMQ broker.
>>
>> I took a look at the 2 users of (2) (identified by their IP) and their
>> connection had a FIN_WAIT state on the netstat command, these 2 clients
>> are
>> hanging
>>
>> It seems there was a brief network outage and caused the 2 users to broke
>> connection with JMS Server causing the FIN_WAIT status on their
>> connection.
>> This in turn somehow hold up the JMS Server from serving the other
>> clients.
>>
>> Is this a known problem? Any fix/workaround for this?
> 
> Are you using the failover transport for your clients to connect to the
> broker?
> 
> http://activemq.apache.org/failover-transport-reference.html
> 
> In the event of a disconnect, the failover transport will
> automatically re-establish a connection for a client.
> 
> Bruce
> -- 
> perl -e 'print
> unpack("u30","D0G)U8V4\@4VYY9&5R\"F)R=6-E+G-N>61E<D\!G;6%I;\"YC;VT*"
> );'
> 
> ActiveMQ in Action: http://bit.ly/2je6cQ
> Blog: http://bruceblog.org/
> Twitter: http://twitter.com/brucesnyder
> 
> 

-- 
View this message in context: http://old.nabble.com/AMQ-hangs-on-FIN_WAIT-tp27669417p27669845.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message