activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "js.w" <js.wal...@gmx.net>
Subject ActiveMQ looses messages under windows 2003
Date Fri, 19 Feb 2010 16:53:02 GMT

Hi,

In the last few days I've tried several configurations on several servers
and saw some rather unusual results which I can't really figure out.
I have a simple scenario for the JMS Server. A process adds about 10k
messages (about 1kb size each) to a queue. A second process reads all the
messages and acknowledges them by auto-ack (I also tried explicit confirms).
I tried this scenario on 2 different machines with different results. On
Linux, all messages are passed on exactly as expected. On Windows on the
other hand quite a lot of the messages (about 10%) get lost. The sender
successfully sends 10k messages and has 10k message-ids. The web-interface
on the other hand only shows something about 9k messages in the queue and
the next worker only gets the 9k messages delivered.
Both environments have the same version of Java, ActiveMQ and config.

So far I can only exclude the client as cause, because on Linux and Windows,
both behave the same way. So the problem should exist somewhere in the
server part.

machine 1:
 64bit debian testing
 ActiveMQ 5.3
 changed the config to disable flowcontrol (otherwise config left
untouched) 
 Java 6

machine 2:
 32 Windows 2003 (sp2)
 ActiveMQ 5.3
 changed the config to disable flowcontrol (otherwise config left
untouched) 
 Java 6

PS: I already tried the following connection parameters without any luck
   optimizedMessageDispatch
   useCompression
     On the server side I tried different stores (kahaDB, Oracle,Postgres)
-> all with the same result
   I also tried running the Server with Java5 which also had no effect on
the behavior.

Does anybody have a clue or idea where the problem lies or how to explain
the discrepancy?

Thanks in advance.
Regards, jens
-- 
View this message in context: http://old.nabble.com/ActiveMQ-looses-messages-under-windows-2003-tp27656958p27656958.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message