activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From khunter <khun...@allmanint.com>
Subject Re: SAXParseException using default activemq.xml
Date Mon, 08 Feb 2010 20:25:42 GMT

Yes, I was using Spring 3.0.  (I didn't notice until you mentioned it that
the ActiveMQ distribution is using Spring 2.5.6.  I guess somewhere between
the two the parsing started paying attention to the schema.  When I switched
over to the spring jars that came with the distribution, it worked find. 
(Duh!)

The activemq.xml file does, in fact, violate the activemq.xsd schema
provided in activemq-core-5.3.0.jar.  The "broker" tag is defined (perhaps
incorrectly) as a sequence in which the sub-tags are in alphabetical order,
and 'destinationPolicy' is out of order.

This feels like a bug to me - you'd think that the distribution activemq.xml
would match the schema :)  Guess I'll file one...

Thanks for your help!


Dejan Bosanac wrote:
> 
> Hi,
> 
> are you using Spring 3.0 in your application? I've seen this when tried to
> upgrade Spring to 3.0. Still didn't find time to dig into the root of the
> problem, but basically it seems that ordering of elements is now
> necessary.
> So just, move 'destinationPolicy' tag up and everything should be fine.
> 
> Cheers
> --
> Dejan Bosanac - http://twitter.com/dejanb
> 
> Open Source Integration - http://fusesource.com/
> ActiveMQ in Action - http://www.manning.com/snyder/
> Blog - http://www.nighttale.net
> 
> 
> 
> 

-- 
View this message in context: http://old.nabble.com/SAXParseException-using-default-activemq.xml-tp27502989p27505648.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message