activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From yair <y...@sundaysky.com>
Subject Broker started in Tomcat is stuck on startup
Date Mon, 08 Feb 2010 15:54:54 GMT

Hi all
I m using this spring + xbeans configuration to start the broker with my
webapp:
	<amq:broker useJmx="true" persistent="true" brokerName="myBroker"
		start="true">
		<amq:persistenceAdapter>
			<amq:jdbcPersistenceAdapter dataDirectory="activemq-data"
				dataSource="#sqlserver-ds">
			</amq:jdbcPersistenceAdapter>
		</amq:persistenceAdapter>
		<amq:transportConnectors>
			<amq:transportConnector uri="tcp://localhost:61616" />
		</amq:transportConnectors>
	</amq:broker>

	<bean id="sqlserver-ds"
		class="com.microsoft.sqlserver.jdbc.SQLServerConnectionPoolDataSource">
		<property name="URL"
			value="jdbc:sqlserver://localhost:1433;databaseName=MYDB" />
		<property name="user" value="sa" />
		<property name="password" value="1234" />
	</bean>

When I start my webapp, it says:
17:48:44,093 [main] WARN 
org.apache.activemq.store.jdbc.JDBCPersistenceAdapter - Database adapter
driver override not found for : [microsoft_sql_server_jdbc_driver_2_0]. 
Will use default implementation.
17:48:44,187 [main] WARN 
org.apache.activemq.store.jdbc.JDBCPersistenceAdapter - Database lock driver
override not found for : [microsoft_sql_server_jdbc_driver_2_0].  Will use
default implementation.

And the main thread is stuck (till eclipse decides that's enough, after 3
minutes...).

I've successfully ran the broker as a standalone (using activemq.bat) with a
similar configuration of activemq.xml, but I need to start with my webapp.
Is there a problem in the xbeans configuration?

Thanks
Yair
-- 
View this message in context: http://old.nabble.com/Broker-started-in-Tomcat-is-stuck-on-startup-tp27501966p27501966.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message