activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From samp <...@brightcove.com>
Subject Re: response never delivered using JMSCorrelationId
Date Fri, 05 Feb 2010 12:06:20 GMT

Thanks for the pointer. I definitely wasn't setting duplex and it sounds like
I need it. This is my new config (duplex just added). I've bounced both
brokers but it appears I'm still seeing the same problem. 

<beans
  xmlns="http://www.springframework.org/schema/beans"
  xmlns:amq="http://activemq.apache.org/schema/core"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans-2.0.xsd
  http://activemq.apache.org/schema/core
http://activemq.apache.org/schema/core/activemq-core.xsd   
  http://activemq.apache.org/camel/schema/spring
http://activemq.apache.org/camel/schema/spring/camel-spring.xsd">

    <broker xmlns="http://activemq.apache.org/schema/core" 
            brokerName="Broker"
	    persistent="false">

        <!-- Use the following to configure how ActiveMQ is exposed in JMX
-->
        <managementContext>
            <managementContext createConnector="false"/>
        </managementContext>

        <!-- The store and forward broker networks ActiveMQ will listen to
-->
        <networkConnectors>
            <networkConnector name="pods"
uri="static://(tcp://activemq1:61616,tcp://activemq2:61616)" duplex="true"/>
        </networkConnectors>

        <transportConnectors>
            <transportConnector name="openwire" uri="tcp://localhost:61616"
discoveryUri="multicast://default"/>
        </transportConnectors>
        <plugins>
            <loggingBrokerPlugin/>
        </plugins>
    </broker>
</beans>


Gary Tully wrote:
> 
> can you post the configuration of the brokers? sounds like you need a
> duplex
> networkconnector or a networkconnector (as they are one way by default)
> configured on each broker.
> see:
> http://activemq.apache.org/networks-of-brokers.html#NetworksofBrokers-NetworkConnectorProperties
> 
> 
> On 5 February 2010 01:27, samp <sam@brightcove.com> wrote:
> 
>>
>> I'm using spring integrations JmsOutboundGateway. I believe the problem
>> I'm
>> seeing is a configuration issue with ActiveMQ which is why I am posting
>> the
>> question here.
>>
>> I have 2 brokers (call them A and B) in a network each with a couple
>> clients
>> connected to them. I am getting into a situation where a response
>> destined
>> for a client connected to Broker A never reaches the consumer that is
>> sitting on Broker B. I use jmx to browse the queue on Broker A and I see
>> the
>> message with a JMSCorrelationId.  I can also see in jmx that there is a
>> queue subscriber waiting on Broker B.
>>
>> It works just fine in revers. If the client connected to Broker B sends
>> the
>> message, there is no problem. The message is delivered and everything is
>> fine.
>>
>> I'm look for suggestions on how to debug this problem.
>>
>> thanks
>> sam
>> --
>> View this message in context:
>> http://old.nabble.com/response-never-delivered-using-JMSCorrelationId-tp27462376p27462376.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>>
> 
> 
> -- 
> http://blog.garytully.com
> 
> Open Source Integration
> http://fusesource.com
> 
> 

-- 
View this message in context: http://old.nabble.com/response-never-delivered-using-JMSCorrelationId-tp27462376p27466910.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message