activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From theHunt <s_pavla...@yahoo.gr>
Subject Unexpected message consumption delays
Date Tue, 02 Feb 2010 16:35:19 GMT

Hi all,

I am facing the following problem, so I could use your help.

We are using a rather simple setup.

activemq5.3 as an embedded broker (kaha store) 
in a tomcat6.0.16 servlet container 
on a windows 2008 64x server machine (Sun JDK 1.6.0_16 64 bit).

We use 1 Queue.
There is one application producing messages, and a number of applications
consuming them (Client Acknowledgment).
Each application consumes its own messages by using selectors. Consumers use
MessageListener implementations.
The current workload is trivial. 1-3 relatively small ObjectMessages per
minute.

So the problem is... random but usual delays in message delivery. No
messages are lost, everything works fine apart from the fact that 60% of the
messages gets consumed 1 to 5 minutes later than the time they were
delivered to the queue. Another 40% gets consumed right away. This is
definitely not because of any workload factor. One hint i got though, is
that when through JMX we purged the Queue from unconsumed messages (about
200 old messages because there was no deployed consumer for them) the delays
became shorter in length and occurred less frequently. but still existed and
reached 1-2 mins.

I think this is unexpected behavior, so I would appreciate your help! 

Thx in advance.

-- 
View this message in context: http://old.nabble.com/Unexpected-message-consumption-delays-tp27423339p27423339.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message