activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: Initial NMS Build with NAnt does Nothing
Date Thu, 18 Feb 2010 15:58:13 GMT
On Thu, 2010-02-18 at 07:43 -0800, curtis_schlak wrote:
> Using NAnt 0.86 (Build 0.86.3412.0; nightly; 5/5/2009), when I run nant at
> the command line, I receive the build output at the end of the message. It
> seems to do nothing except create the lib\NUnit\net-X.X and
> build\net-X.X\[Debug|Release] sub-directories.
> 
> Any assistance in getting this initial build completed would really help.
> 

To build the NMS clients from source you first need to initialize the
NAnt repository with the required dependencies that are needed to run
the tests.  The simplest way to do that is to checkout the vendors
branch in our SVN repo here:

<https://svn.apache.org/repos/asf/activemq/activemq-dotnet/vendor>

cd into the vendors/NUnit/2.4.8 directory and run nant install and the
NUnit DLLs will get installed into the correct location, then when you
run the NAnt build on NMS it should work.

Regards
Tim.



> BUILD OUTPUT (with blank lines removed)
> ---------------------------------------
> NAnt 0.86 (Build 0.86.3412.0; nightly; 5/5/2009)
> Copyright (C) 2001-2009 Gerry Shaw
> http://nant.sourceforge.net
> Buildfile: file:///C:/Documents and
> Settings/schlakcu/Desktop/NMS/Apache.NMS/nant.build
> Target framework: Microsoft .NET Framework 3.5
> Target(s) specified: default 
> install-all:
>      [echo] Installing all build configurations for all runtime
> configurations.
> init:
> set-debug-configuration:
> set-net-2.0-framework-configuration:
>  [property] Target framework changed to "Microsoft .NET Framework 2.0".
>      [echo] Doing a signed debug build for the .NET 2.0 framework
> dependency-init:
> vendor-init:
> conditional-download:
>      [echo] Required dependent assembly nunit.framework.dll from NUnit for
> .NET 2.0 is not available. Build skipped.
>      [echo] Required dependent assembly nunit.framework.extensions.dll from
> NUnit for .NET 2.0 is not available. Build skipped.
> download-vendor:
> compile-target:
> install:
> init:
> set-release-configuration:
> set-net-2.0-framework-configuration:
>      [echo] Doing a signed release build for the .NET 2.0 framework
> dependency-init:
> vendor-init:
> conditional-download:
>      [echo] Required dependent assembly nunit.framework.dll from NUnit for
> .NET 2.0 is not available. Build skipped.
>      [echo] Required dependent assembly nunit.framework.extensions.dll from
> NUnit for .NET 2.0 is not available. Build skipped.
> download-vendor:
> compile-target:
> install:
> init:
> set-debug-configuration:
> set-net-3.5-framework-configuration:
>  [property] Target framework changed to "Microsoft .NET Framework 3.5".
>      [echo] Doing a signed debug build for the .NET 3.5 framework
> dependency-init:
> vendor-init:
> conditional-download:
>      [echo] Required dependent assembly nunit.framework.dll from NUnit for
> .NET 3.5 is not available. Build skipped.
>      [echo] Required dependent assembly nunit.framework.extensions.dll from
> NUnit for .NET 3.5 is not available. Build skipped.
> download-vendor:
> compile-target:
> install:
> init:
> set-release-configuration:
> set-net-3.5-framework-configuration:
>      [echo] Doing a signed release build for the .NET 3.5 framework
> dependency-init:
> vendor-init:
> conditional-download:
>      [echo] Required dependent assembly nunit.framework.dll from NUnit for
> .NET 3.5 is not available. Build skipped.
>      [echo] Required dependent assembly nunit.framework.extensions.dll from
> NUnit for .NET 3.5 is not available. Build skipped.
> download-vendor:
> compile-target:
> install:
> init:
> set-debug-configuration:
> set-mono-2.0-framework-configuration:
>      [echo] Mono 2.0 is not available. Build skipped.
> dependency-init:
> vendor-init:
> download-vendor:
> compile-target:
> install:
> init:
> set-release-configuration:
> set-mono-2.0-framework-configuration:
>      [echo] Mono 2.0 is not available. Build skipped.
> dependency-init:
> vendor-init:
> download-vendor:
> compile-target:
> install:
> init:
> set-debug-configuration:
> set-netcf-2.0-framework-configuration:
>      [echo] .NET Compact Framework 2.0 is not available. Build skipped.
> dependency-init:
> vendor-init:
> download-vendor:
> compile-target:
> install:
> init:
> set-release-configuration:
> set-netcf-2.0-framework-configuration:
>      [echo] .NET Compact Framework 2.0 is not available. Build skipped.
> dependency-init:
> vendor-init:
> download-vendor:
> compile-target:
> install:
> init:
> set-debug-configuration:
> set-netcf-3.5-framework-configuration:
>      [echo] .NET Compact Framework 3.5 is not available. Build skipped.
> dependency-init:
> vendor-init:
> download-vendor:
> compile-target:
> install:
> init:
> set-release-configuration:
> set-netcf-3.5-framework-configuration:
>      [echo] .NET Compact Framework 3.5 is not available. Build skipped.
> dependency-init:
> vendor-init:
> download-vendor:
> compile-target:
> install:
> default:
> BUILD SUCCEEDED
> Total time: 1 seconds.
> 

-- 
Tim Bish

Open Source Integration: http://fusesource.com
ActiveMQ in Action: http://www.manning.com/snyder/

Follow me on Twitter: http://twitter.com/tabish121
My Blog: http://timbish.blogspot.com/


Mime
View raw message