activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Lloyd <jll...@silvertailsystems.com>
Subject Re: Upgrading from activemq-cpp 2.2 to 3.1
Date Thu, 07 Jan 2010 23:11:56 GMT
Whoops! Sorry, I meant to hit save and not send, since I suddenly realized
what might be the cause of my problem. And indeed, I was right, so I no
longer need assistance. But thanks anyway for replying quickly!

My problem was indeed related to initializing the library, and I had figured
out that I needed to do so from looking at the sample apps. My code was
compiling but not linking. It turns out that I had a subtle error in my
build system and was still linking against old libraries.

I seem to recall that there was some kind of document describing other
changes that may be necessary in upgrading from 2.x to 3.x, but if there is
I haven't been able to find it. Is there one?

Jim

On Thu, Jan 7, 2010 at 2:36 PM, Timothy Bish <tabish121@gmail.com> wrote:

> On Thu, 2010-01-07 at 14:27 -0800, Jim Lloyd wrote:
> > I'm finally upgrading some applications to use activemq-cpp 3.1.1. We had
> > been using 2.2.6
>
> Great, let us know how it goes, lots of new features in there.
>
> Make sure you take a look at the sample apps for some hints on the
> changes, you need to initialize and uninitialize the library now, FYI.
>
> Regards
> Tim.
>
>
>
> --
> Tim Bish
> http://fusesource.com
> http://timbish.blogspot.com/
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message