activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Davies <rajdav...@gmail.com>
Subject Re: Could not connect to broker URL: tcp remote connection failure
Date Tue, 19 Jan 2010 21:21:43 GMT
ok - thanks for the feedback!

On 19 Jan 2010, at 21:05, quinn wrote:

>
> Thanks very much for the response.
>
> After rebooting it is working again. If I can reproduce, I will post  
> again.
>
>
>
> rajdavies wrote:
>>
>> ok - some basic things to re-check - just in case:
>> 1. so in the broker config only you have set tcp://0.0.0.0:port
>> 2. your remote client is using tcp://hostname:port to connect to your
>> broker
>> 3. you don't have a rouge broker on your remote client's machine that
>> its connected to
>> 4. your remote client isn't using an embedded broker too ?
>>
>>
>> On 18 Jan 2010, at 03:26, quinn wrote:
>>
>>>
>>> I spoke too soon.
>>>
>>> While this solution did allow my client to connect from a remote
>>> client
>>> without exceptions thrown, when I try to push data through, nothing
>>> happens.
>>> Yet, when I run the server and the client on the same machine, the
>>> data
>>> flows.
>>>
>>> Any further ideas?
>>>
>>> Thanks in advance.
>>>
>>>
>>>
>>> quinn wrote:
>>>>
>>>> That fixed the problem.
>>>> Thanks very much!
>>>> How would I have figured that out? I don't recall seeing 0.0.0.0 in
>>>> any of
>>>> the examples.
>>>>
>>>> Cheers.
>>>>
>>>> TQ
>>>>
>>>>
>>>> rajdavies wrote:
>>>>>
>>>>> instead of defining tcp://localhost:port  in your broker config -
>>>>> try
>>>>> tcp://0.0.0.0:port
>>>>> On 15 Jan 2010, at 22:43, quinn wrote:
>>>>>
>>>>>>
>>>>>> I am using ActiveMQ 5.3 and JDK 1.6.
>>>>>>
>>>>>> I have a XP box and an Ubuntu box. On either machine I can  
>>>>>> start an
>>>>>> embedded
>>>>>> broker and the vm and tcp transports work well on one machine.  
>>>>>> When
>>>>>> I try to
>>>>>> access the tcp transport from a remote machine I am unable to
>>>>>> connect.
>>>>>>
>>>>>> The stack trace is attached.
>>>>>> http://old.nabble.com/file/p27184667/stackTrace.txt  
>>>>>> stackTrace.txt
>>>>>>
>>>>>> The broker is create with the following code:
>>>>>>              System.setProperty("activemq.base",
>>>>>> System.getProperty("user.dir"));
>>>>>> 		BrokerService broker = BrokerFactory.createBroker(new
>>>>>> URI("xbean:mdBroker.xml"));
>>>>>> 		broker.start();
>>>>>> The mdBroker.xml file is also attached.
>>>>>> http://old.nabble.com/file/p27184667/mdBroker.xml mdBroker.xml
>>>>>>
>>>>>> The subscriber is configured with the following URI
>>>>>>              "tcp://192.168.1.5:6000"
>>>>>> I can provide the code for the client, but it seems unnecessary
>>>>>> since it
>>>>>> does work within the same machine.
>>>>>>
>>>>>> I have spent a few days trying to resolve this problem and gone
>>>>>> through the
>>>>>> reference manual and looked through the MEAD ActiveMQ in Action
>>>>>> without
>>>>>> finding a solution.
>>>>>>
>>>>>> I am sure the process is up and running from running netstat -ln.
>>>>>> http://old.nabble.com/file/p27184667/netstat.txt netstat.txt
>>>>>>
>>>>>> I also know that a connection is possible because I have  
>>>>>> written a
>>>>>> simple
>>>>>> echo server and echo client that can connect without issue. I can
>>>>>> provide
>>>>>> the code if desired.
>>>>>>
>>>>>> I do not know what I am missing here. I have tried to create the
>>>>>> broker with
>>>>>> the Spring configuration and problematically with the same
>>>>>> result. Any
>>>>>> insight would be greatly appreciated.
>>>>>>
>>>>>> Thanks in advance.
>>>>>>
>>>>>> TQ
>>>>>>
>>>>>>
>>>>>>
>>>>>> -- 
>>>>>> View this message in context:
>>>>>> http://old.nabble.com/Could-not-connect-to-broker-URL%3A-tcp-remote-connection-failure-tp27184667p27184667.html
>>>>>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>>>>>
>>>>>
>>>>> Rob Davies
>>>>> http://twitter.com/rajdavies
>>>>> I work here: http://fusesource.com
>>>>> My Blog: http://rajdavies.blogspot.com/
>>>>> I'm writing this: http://www.manning.com/snyder/
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>>> -- 
>>> View this message in context:
>>> http://old.nabble.com/Could-not-connect-to-broker-URL%3A-tcp-remote-connection-failure-tp27184667p27205780.html
>>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>>
>>
>> Rob Davies
>> http://twitter.com/rajdavies
>> I work here: http://fusesource.com
>> My Blog: http://rajdavies.blogspot.com/
>> I'm writing this: http://www.manning.com/snyder/
>>
>>
>>
>>
>>
>>
>>
>
> -- 
> View this message in context: http://old.nabble.com/Could-not-connect-to-broker-URL%3A-tcp-remote-connection-failure-tp27184667p27232709.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>

Rob Davies
http://twitter.com/rajdavies
I work here: http://fusesource.com
My Blog: http://rajdavies.blogspot.com/
I'm writing this: http://www.manning.com/snyder/






Mime
View raw message