activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tammer Salem <tammer.sa...@googlemail.com>
Subject Re: NMS Stomp Transport Connection Error
Date Mon, 25 Jan 2010 15:05:53 GMT
Thanks! I'm able to get a connection now.

(sorry for the noob question - it's not that clear in the documentation)

2010/1/25 Timothy Bish <tabish121@gmail.com>

> On Mon, 2010-01-25 at 14:32 +0000, Tammer Salem wrote:
> > Yep - I'm pretty sure the broker is running. The only thing I'm not too
> sure
> > of is the connector is defined as:
> >
> > <transportConnector name="stomp"
> uri="stomp://localhost:61613?trace=true"/>
> >
> > but my URL I'm connecting with is:
> >
> > String connecturi = "stomp:tcp://10.243.169.4:61613";
> >
> > I'm still a bit of a noob with the connection URLs and I'm not sure if
> this
> > is correct or not. Certainly when I'm stepping through debug, all the
> > parsing seems correct.
>
> the localhost in the config for the stomp transpotConnector binds to
> loopback so you probably want to change that to 0.0.0.0:61613 then it
> should work.
>
> Regards
> Tim.
>
> >
> > 2010/1/25 Timothy Bish <tabish121@gmail.com>
> >
> > > On Mon, 2010-01-25 at 13:59 +0000, Tammer Salem wrote:
> > > > Hello All,
> > > > I'm trying to connect to activemq on my local machine using a .netcf
> > > > stomp client on a pocket pc 2005 emulator. I'm sure connectivity is
> > > working
> > > > fine (I can get to the demo page from the emulator). The problem is
> when
> > > I
> > > > try to call:
> > > >
> > > > IConnection connection = factory.CreateConnection();
> > > >
> > > > This eventually ends in a TcpTransportFactory exception. When I've
> traced
> > > > it, I've seen that it errors in the ConnectSocket() method when
> trying to
> > > > create a new Socket.
> > > >
> > > > My Debug output also shows:
> > > > A first chance exception of type 'System.Net.Sockets.SocketException'
> > > > occurred in System.dll
> > > > A first chance exception of type 'System.Net.Sockets.SocketException'
> > > > occurred in Apache.NMS.Stomp.dll
> > > > A first chance exception of type 'Apache.NMS.NMSConnectionException'
> > > > occurred in Apache.NMS.Stomp.dll
> > > > A first chance exception of type 'System.NullReferenceException'
> occurred
> > > in
> > > > Apache.NMS.Stomp.dll
> > > > A first chance exception of type 'Apache.NMS.NMSConnectionException'
> > > > occurred in Apache.NMS.Stomp.dll
> > > >
> > > > Does anyone have any idea why I would be getting this? (I have
> replicated
> > > > the problem on a completely different machine so I'm relatively
> certain
> > > that
> > > > the problem is not connectivity from the emulator).
> > > >
> > > > regards,
> > > > Tammer
> > >
> > > Have you looked at the message that's provided form the exception that
> > > gets thrown?  Are you sure there's a broker active and configured with
> a
> > > stomp transport at the location your URI if pointing to?
> > >
> > > Regards
> > > Tim.
> > >
> > >
> > >
> > > --
> > > Tim Bish
> > > http://fusesource.com
> > > http://timbish.blogspot.com/
> > >
> > >
> > >
> > >
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message