activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jeff yung <yung...@hotmail.com>
Subject webconsole-invm.xml: factory-bean 'brokerService' returned null
Date Tue, 12 Jan 2010 02:19:00 GMT

I am integrating jboss and activemq (5.3.0) broker + activemq webconsole.
There is no problem with the activemq broker, the exception occurs when I
deploy the webconsole in "invm" mode. (Use one broker only)

Part of the stack trace:

2010-01-12 10:07:59,374 INFO  [STDOUT] 2010-01-12 10:07:59,358 [main          
] ERROR 0]                             - Exception sending context
initialized event to listener instance of class
org.apache.activemq.web.WebConsoleStarter
org.springframework.beans.factory.BeanCreationException: Error creating bean
with name 'sessionPool' defined in ServletContext resource
[/WEB-INF/webconsole-invm.xml]: Cannot resolve reference to bean
'connectionFactory' while setting bean property 'connectionFactory'; nested
exception is org.springframework.beans.factory.BeanCreationException: Error
creating bean with name 'connectionFactory' defined in ServletContext
resource [/WEB-INF/webconsole-invm.xml]: Cannot resolve reference to bean
'brokerURL' while setting constructor argument; nested exception is
org.springframework.beans.factory.BeanCreationException: Error creating bean
with name 'brokerURL' defined in ServletContext resource
[/WEB-INF/webconsole-invm.xml]: factory-bean 'brokerService' returned null
	at
org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveReference(BeanDefinitionValueResolver.java:275)
	at
org.springframework.beans.factory.support.BeanDefinitionValueResolver.resolveValueIfNecessary(BeanDefinitionValueResolver.java:104)
	at
org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.applyPropertyValues(AbstractAutowireCapableBeanFactory.java:1245)
	at
org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.populateBean(AbstractAutowireCapableBeanFactory.java:1010)
	at
org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:472)
	at
org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory$1.run(AbstractAutowireCapableBeanFactory.java:409)
	at java.security.AccessController.doPrivileged(Native Method)


When I debug the broker and webconsole, I found the broker is binded in
BrokerRegistry class:

    public void bind(String brokerName, BrokerService broker)  

However, when the lookup function is called, it returns null. The reason is
that the bind and lookup calls are on 2 different BrokerRegistry instances.
I guess one is broker while another is webconsole. 

Anyone know how to solve this problem. Thanks.

Jeff 


-- 
View this message in context: http://old.nabble.com/webconsole-invm.xml%3A-factory-bean-%27brokerService%27-returned-null-tp27121392p27121392.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message