activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "H. Willstrand" <h.willstr...@gmail.com>
Subject Re: ActiveMQ 5.2.0 Multicast errors on startup
Date Wed, 06 Jan 2010 22:54:48 GMT
On Wed, Jan 6, 2010 at 11:46 PM, Patel, Ronak Avinash (US SSA)
<ronak.patel@baesystems.com> wrote:
> Hi All,
>
> I've been using Apache ActiveMQ 5.2.0 on RHEL 5.3 and everything's been working great.
>
> However, I wanted to ask if anyone has ever successfully gotten Apache ActiveMQ to turn
on when the computer boots?
>
> I have a startup script for activemq located in /etc/init.d with /etc/rc5.d/S99activemq
pointing to it.
>
> However, I'm getting this exception when ActiveMQ starts:
>
> 2010-01-06 13:45:14,269 [cture-xsp:61616] ERROR MulticastDiscoveryAgent        -
>  Failed to advertise our service: default.ActiveMQ-4.alive.%localhost%tcp://m222
> -infrastructure-xsp:61616
> java.io.IOException: Network is unreachable
>        at java.net.PlainDatagramSocketImpl.send(Native Method)
>        at java.net.DatagramSocket.send(DatagramSocket.java:612)
>        at org.apache.activemq.transport.discovery.multicast.MulticastDiscoveryA
> gent.doAdvertizeSelf(MulticastDiscoveryAgent.java:390)
>        at org.apache.activemq.transport.discovery.multicast.MulticastDiscoveryA
> gent.doTimeKeepingServices(MulticastDiscoveryAgent.java:374)
>        at org.apache.activemq.transport.discovery.multicast.MulticastDiscoveryA
> gent.run(MulticastDiscoveryAgent.java:336)
>        at java.lang.Thread.run(Thread.java:619)
>
> This only occurs when I try to start ActiveMQ when I start it on boot. After Linux boots
up to the desktop, I can start it just fine using the same script.
>
> Has anyone ever seen this?
>
Seams to be the network that is not yet started. Suggest that you try
start your script from rc.local instead.

//H.W
> Thanks!
>
> Ronak Patel
> Senior Software Engineer
> BAE Systems NS
> San Diego, CA
>
>

Mime
View raw message