activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: Subscription lost while
Date Tue, 26 Jan 2010 13:59:56 GMT
On Tue, 2010-01-26 at 10:28 +0800, Sebastian Rodriguez wrote:

> 
> What can be the causes to receive the exception Unable to read beyond the
> end of the stream? I've seen a jira speaking about it (
> http://issues.apache.org/activemq/browse/AMQNET-196) but i do not receive
> this exception in a regular basis. It seems that this exception occurs more
> often in slow or old machines. Can it be related?

My guess would be that's its taking to long for these slower machines to
process a message and are being timed out because they exceed their max
Inactivity Duration setting.  You could try increasing the inactivity
timeout from the default of 30 seconds to something larger, or turn off
inactivity monitoring and see if the problem goes away.

Regards
Tim.


> 
> Thank you very much for your help on the subject,
> 
> Sebastien
> 2010/1/25 Sebastian Rodriguez <srodrigu85@gmail.com>
> 
> > I've enabled the logging and left the client running during the night.
> > Hopefully I'll be able to come back to you tomorrow with more details.
> > The "funny" thing, is that there is no connection lost, we "only" looses
> > the subscriptions.
> > I'll try to make a sample tomorrow see if i can reproduce the error
> >
> > 2010/1/25 Timothy Bish <tabish121@gmail.com>
> >
> >> On Mon, 2010-01-25 at 12:18 +0800, Sebastian Rodriguez wrote:
> >>


-- 
Tim Bish
http://fusesource.com
http://timbish.blogspot.com/




Mime
View raw message