activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: BadImageFormatException with Apache.NMS.ActiveMQ‏
Date Mon, 18 Jan 2010 20:01:01 GMT
On Thu, 2010-01-14 at 07:48 -0800, oskareto wrote:
> 
> 
> Timothy Bish wrote:
> > 
> > On Thu, 2010-01-14 at 04:28 -0800, oskareto wrote:
> >> Hello! First, sorry for my English.
> >>  
> >> I'm deploying this example application
> >> http://remark.wordpress.com/articles/publish-subscribe-with-activemq-and-nms/
> >> . When I've created all the project and i've downloaded the requiered
> >> dll's
> >> (Apache.NMS 1.2.0 and Apache.NMS.ActiveMQ), and I execute the
> >> application,
> >> the VS2008 throws an exception: "No se puede cargar el archivo o
> >> ensamblado
> >> 'Apache.NMS.ActiveMQ, Version=1.2.0.1823, Culture=neutral,
> >> PublicKeyToken=82756feee3957618' ni una de sus dependencias. Se esperaba
> >> que
> >> el módulo tuviera un manifiesto de ensamblado.". I don`t know what's
> >> happends. I've seen that if I comment the code of creatting a conection,
> >> the
> >> problem dissapears, but obviously the application don't works. 
> >>  
> >> Can any one help me please? I don't know if the problem is in config file
> >> or
> >> where (I've read that in version 1.2.0 the config files are not
> >> necessary).
> >>  
> >> Thank you very much!
> > 
> > I would ensure that you have the correct versions of the DLL files, the
> > latest Release candidates are here:
> > http://people.apache.org/~tabish/nms-1.2.0-RC2/
> > 
> > You don't need configuration files, just place both DLL files in the
> > same location and add references to them to you project.
> > 
> > Regards
> > Tim.
> > 
> > -- 
> > Tim Bish
> > http://fusesource.com
> > http://timbish.blogspot.com/
> > 
> > 
> 
> Thanks Tim.
> 
> The two DLL I've downloaded are of this page (version 1.2.0.1823) with the
> .NET Framework 3.5. I'm sure too that the DLLs are the correct for this
> framework version. I don't know where is the problem....
> 

This error is due to the various builds that are out there right now and
the version referenced in the NMS.ActiveMQ DLL doesn't match the version
of the Apache.NMS.Dll you are using.  You can use an app-config file to
redirect things or just download the release version of Apache.NMS from
the NMS website and then get the latest release candidate of
Apache.NMS.ActiveMQ here:

http://people.apache.org/~tabish/nms.activemq-1.2.0/

Regards
Tim.



Mime
View raw message