activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patel, Ronak Avinash (US SSA)" <ronak.pa...@baesystems.com>
Subject ActiveMQ 5.2.0 Multicast errors on startup
Date Wed, 06 Jan 2010 22:46:23 GMT
Hi All,

I've been using Apache ActiveMQ 5.2.0 on RHEL 5.3 and everything's been working great.

However, I wanted to ask if anyone has ever successfully gotten Apache ActiveMQ to turn on
when the computer boots?

I have a startup script for activemq located in /etc/init.d with /etc/rc5.d/S99activemq pointing
to it.

However, I'm getting this exception when ActiveMQ starts:

2010-01-06 13:45:14,269 [cture-xsp:61616] ERROR MulticastDiscoveryAgent        -
 Failed to advertise our service: default.ActiveMQ-4.alive.%localhost%tcp://m222
-infrastructure-xsp:61616
java.io.IOException: Network is unreachable
        at java.net.PlainDatagramSocketImpl.send(Native Method)
        at java.net.DatagramSocket.send(DatagramSocket.java:612)
        at org.apache.activemq.transport.discovery.multicast.MulticastDiscoveryA
gent.doAdvertizeSelf(MulticastDiscoveryAgent.java:390)
        at org.apache.activemq.transport.discovery.multicast.MulticastDiscoveryA
gent.doTimeKeepingServices(MulticastDiscoveryAgent.java:374)
        at org.apache.activemq.transport.discovery.multicast.MulticastDiscoveryA
gent.run(MulticastDiscoveryAgent.java:336)
        at java.lang.Thread.run(Thread.java:619)

This only occurs when I try to start ActiveMQ when I start it on boot. After Linux boots up
to the desktop, I can start it just fine using the same script.

Has anyone ever seen this?

Thanks!

Ronak Patel
Senior Software Engineer
BAE Systems NS
San Diego, CA


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message