activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: ActiveMQ brokers version upgrade rules
Date Mon, 21 Dec 2009 12:31:42 GMT
So the theory is that openwire protocol version negotiation(down to the
lowest common denominator) will work just find with this mix. The problem is
that it needs to be validated or verified for your feature set, this is not
covered by the hudson nighty builds, the permutations just get out of hand.
5.2 clients to 5.3 brokers should be fine. 5.2 broker to 5.3 broker to
broker comms may depend on the feature set enabled on the network connectors
but should be find with a vanilla 5.2 config.
So there is no "rule" but we do try and ensure backward compatibility
through wire format updates. The reality is that you need to "ask the
computer" on this one to be sure with the knowledge that the theory is on
your side.
And publish your results!


2009/12/20 Eric-AWL <eric.vincent@atosorigin.com>

>
> Hi
>
> I want to upgrade from 5.2 to 5.3. I don't want to have to stop all my
> brokers simultaneously but would rather stop and restart them one after the
> other.
>
> Is it possible to simultaneously have 5.2 and 5.3 brokers that exchange
> messages together ?
>
> Generally speaking, does ActiveMQ programmers follow a rule about this
> general upgrade problem ? If yes, what is this rule ?
>
> Thank you in advance
> Eric-AWL
> --
> View this message in context:
> http://old.nabble.com/ActiveMQ-brokers-version-upgrade-rules-tp26861693p26861693.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>


-- 
http://blog.garytully.com

Open Source Integration
http://fusesource.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message