activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: Upgrading to Spring 3.0.0
Date Fri, 18 Dec 2009 12:17:06 GMT
Hi,

I guess you need to add spring-jms to your application's class path
(http://repo1.maven.org/maven2/org/springframework/spring-jms/3.0.0.RELEASE/)
if you want use jms-specific spring features.

Cheers
--
Dejan Bosanac - http://twitter.com/dejanb

Open Source Integration - http://fusesource.com/
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net



On Fri, Dec 18, 2009 at 6:52 AM, amarcute <amarcute@gmail.com> wrote:
>
>
> Hi,
>
> I'm using ActiveMQ5.2.0/5.3.0 and we have our custom code embedded into
> ActiveMQ. Recently, we have updated our code to use Spring 3.0.0 binaries
> and it seems this is not all OK with the ActiveMQ and it is not starting up.
>
> the problems I observed are:
>
> 1). XBean configuration is not supported (it always complains 'jetty' Schema
> is not found)
> 2). some of the classes are missing
> (org.springframework.jms.listener.serversession.* package is not part  of
> spring-jms 3.0.o jar)
> and other non-compatibility issues.
>
> is there any solution for this? will there be a new release of ActiveMQ
> supporting new spring version?
>
> Please help me on this?
> --
> View this message in context: http://old.nabble.com/Upgrading-to-Spring-3.0.0-tp26839497p26839497.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
View raw message