activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: Getting REST to work with the Broker via https
Date Wed, 16 Dec 2009 08:57:24 GMT
Hi,

you can not mix Jetty and Spring configuration.

Unfortunately, version 6 that we use in ActiveMQ does not support
xbean config for ssl connector. So you need to configure it using
plain spring config. Something like described here
http://coffeaelectronica.com/blog/2008/08/embedding-jetty-6-in-spring/
just adapted to your needs (and with ssl connector).

I just created a enhancement request to provide ssl configuration out
of the box in the future versions of activemq
(https://issues.apache.org/activemq/browse/AMQ-2535)

Cheers
--
Dejan Bosanac - http://twitter.com/dejanb

Open Source Integration - http://fusesource.com/
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net



On Tue, Dec 15, 2009 at 12:13 AM, yesnid <nsimi@pelco.com> wrote:
>
> Hello All,
>
> I am having difficulty getting REST & https working in conjunction with each
> other, could any one post a complete example of a activemq.xml config file
> that should provide this behavior?
>
> I have tried adding the following to my configuration:
>            <transportConnector name="https" uri="https://localhost:8443"/>
>
> However i don't know how I should be configuring the Jetty server that is
> started for my certificates.
>
> I also tried:
>
>        <Call name="addConnector">
>            <Arg>
>        <New class="org.mortbay.jetty.security.SslSocketConnector">
>                <Set name="Port">8443</Set>
>          <Set name="maxIdleTime">30000</Set>
>                <Set name="keystore">
>                        <SystemProperty name="jetty.home" default="." />{location}\broker.ks
>                  </Set>
>          <Set name="password">password</Set>
>                <Set name="keyPassword">password</Set>
>          <Set name="truststore">
>                        <SystemProperty name="jetty.home" default="." />{location}\broker.ts
>                  </Set>
>          <Set name="trustPassword">password</Set>
>              </New>
>            </Arg>
>        </Call>
>
> however I get an exception saying it doesn't recognize the bean "Arg"
>
> PLEASE HELP!!!
>
> Thank you,
> --
> View this message in context: http://old.nabble.com/Getting-REST-to-work-with-the-Broker-via-https-tp26780276p26780276.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
View raw message