activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adrian A <adri...@acta.co.uk>
Subject Re: Slow sending of messages
Date Mon, 21 Dec 2009 12:55:00 GMT

Hi Gary

Sorry, yes that config didn't have flow control disabled but have had that
previously, makes no difference. If a producer is being throttled (flow
controlled) will it be logged in the debug?
I can't see any reference to VMPendingMessagecursor and I can't seem to
configure it correctly in the broker, eg:

 <policyEntry queue=">" memoryLimit="500mb" producerFlowControl="false" >
                        <pendingQueuePolicy>
                                <vmPendingMessageCursor />
                        </pendingQueuePolicy>
                    </policyEntry>

results in:
java.lang.Exception:
org.springframework.beans.factory.BeanDefinitionStoreException: Unrecognized
xbean element mapping: vmPendingMessageCursor in namespace
http://activemq.apache.org/schema/core

tried with VM or vm, and can't find any reference on that page (and have
tried several of the cursors already)

Thanks

Adrian

Gary Tully wrote:
> 
> Your policyEntry does not disable producer flow control, add.
> 
> <policyEntry queue=">" memoryLimit="500mb" producerFlowControl="false" />
> 
> also there is a VMPendingMessageCursor that will maintain all references
> in
> memory. See the end of
> http://activemq.apache.org/message-cursors.html for details.
> 
> 

-- 
View this message in context: http://old.nabble.com/Slow-sending-of-messages-tp26849964p26873612.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message