activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jeevanpd <jeevan.dhananja...@ingg.com>
Subject Re: Retroactive consumers are not working in 5.3.0
Date Tue, 01 Dec 2009 22:41:19 GMT

Hi Dejan,

Thanks for you reply.

Retroactive consumers are working for me now but I had to add the following
policy to my broker

			PolicyMap policyMap = new PolicyMap();
			PolicyEntry policy = new PolicyEntry();
			FixedCountSubscriptionRecoveryPolicy fixedCountSubscriptionRecoveryPolicy
= new FixedCountSubscriptionRecoveryPolicy();
			fixedCountSubscriptionRecoveryPolicy.setMaximumSize(10);
		
policy.setSubscriptionRecoveryPolicy(fixedCountSubscriptionRecoveryPolicy);
			policyMap.setDefaultEntry(policy);

In 5.2.0 it was working without this setup

Thanks,
Jeevan


Dejan Bosanac wrote:
> 
> Hi Jeevan,
> 
> all retroactive consumer related tests are passing
> 
> http://svn.apache.org/viewvc/activemq/trunk/activemq-core/src/test/java/org/apache/activemq/test/retroactive/
> 
> Can you provide a similar test case that is failing to you?
> 
> Cheers
> --
> Dejan Bosanac - http://twitter.com/dejanb
> 
> Open Source Integration - http://fusesource.com/
> ActiveMQ in Action - http://www.manning.com/snyder/
> Blog - http://www.nighttale.net
> 
> 
> On Fri, Nov 27, 2009 at 7:24 PM, jeevanpd
> <jeevan.dhananjayan@ingg.com>wrote:
> 
>>
>>
>> Hi All,
>>
>> I have been using activemq 5.2.0 embeded working in a tomcat container.
>> Today I have used the new version 5.3.0 and my retroactive consumers
>> stopped
>> working. When I rolled back to 5.2.0, it started working.
>>
>> Is there any special set up for this compared to version 5.2.0.
>>
>> Helps much appreciated.
>>
>> Thanks,
>> Jeevan
>>
>> --
>> View this message in context:
>> http://old.nabble.com/Retroactive-consumers-are-not-working-in-5.3.0-tp26545360p26545360.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>>
> 
> 
> -----
> Dejan Bosanac
> 
> Open Source Integration - http://fusesource.com/
> ActiveMQ in Action - http://www.manning.com/snyder/
> Blog - http://www.nighttale.net
> 

-- 
View this message in context: http://old.nabble.com/Retroactive-consumers-are-not-working-in-5.3.0-tp26545360p26600352.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.


Mime
View raw message