activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <>
Subject Re: Receiving old messages on durable topics after application restart using ActiveMQ two node cluster
Date Fri, 06 Nov 2009 17:31:58 GMT
Can you share your configuration to show the cluster setup and
destination policies?
Off hand I can't think of any misconfiguration that would behave like this.
Can you reproduce with a short up time?

2009/11/6 Stefan Verhoeff <>:
> Hello,
> We are running a two node cluster of ActiveMQ 5.2. Our application uses
> durable persistent topics, it is both the producer and consumer of the
> messages. The application is configured using the failover:// protocol to
> work with the cluster nodes. The JMS client uses Spring for configuration,
> it's done as described here:
> It all runs fine. But when the application is restarted we start receiving
> old messages that have been consumed in the past. The age of the messages
> seems to correspond to the time of the last restart (for example: 20 days).
> We suspect the cluster nodes are replicating and storing the messages
> correctly but the node that the app is using is not marking the messages as
> 'consumed' on the other node. When on restart the other node is chosen it
> starts sending all messages that were consumed the last run on the other
> node. Is there anything we might have missed in configuration?
> Kind regards,
> Stefan
> --
> View this message in context:
> Sent from the ActiveMQ - User mailing list archive at


Open Source Integration

View raw message