activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: network of brokers forward problem
Date Fri, 13 Nov 2009 12:20:18 GMT
Hi,

try setting lower prefetch size to match your use case
http://activemq.apache.org/what-is-the-prefetch-limit-for.html

Cheers
--
Dejan Bosanac - http://twitter.com/dejanb

Open Source Integration - http://fusesource.com/
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Fri, Nov 13, 2009 at 12:43 PM, nehehe <hakon@teletopia.no> wrote:

>
> Hi,
>
> I'm trying to configure a network of brokers, and it works somewhat but not
> the way I expect.
>
> Two brokers A and B.
>
> 1000 messages are added to broker A
> 10 messages are consumed from broker B, then disconnects (or plugged)
>  (messages are transferred from A->B so thats good)
> Client connects to broker A and try to consume messages.
>
> Now broker B has 990 messages, while the only consumer is connected to A,
> and nothing more happens
>
> My question, is this supposed to work as I expect?
>
>
>
> Im running activemq 5.3.0
>
> The configuration:
>
> transport is configured with keepAlive and soTimeout
>
> <networkConnector
>  name="aaaa"
>  dynamicOnly="true"
>  networkTTL="10"
>  conduitSubscriptions="false"
>  uri="static://(tcp://192.168.20.12:61616)"
> />
>
> Regards,
> Haakon
> --
> View this message in context:
> http://old.nabble.com/network-of-brokers-forward-problem-tp26335357p26335357.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message