activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dejan Bosanac <de...@nighttale.net>
Subject Re: Stomp Connection Dispatcher Fails on NPE
Date Fri, 06 Nov 2009 11:14:47 GMT
Hi,

can you open a jira for this, so it doesn't get lost? It would be great if
you could create a reproducible test case as well.

Cheers
--
Dejan Bosanac - http://twitter.com/dejanb

Open Source Integration - http://fusesource.com/
ActiveMQ in Action - http://www.manning.com/snyder/
Blog - http://www.nighttale.net


On Thu, Nov 5, 2009 at 6:41 PM, bwillis <bwillis@teldio.com> wrote:

>
> We have been using ActiveMQ 5.2 on Windows for about 6months with a
> relatively low message throughput (a maximum usage 1 message every 4
> seconds, nothing crazy) and it was working perfectly.  We have several
> clients that connect through either an OpenWire or Stomp connection and
> communicate through Queues.
>
> Several days ago I started testing higher throughput (several
> messages/second) messaging by publishing to a Queue from an OpenWire
> connection and consuming the message on a Stomp connection.  At some point
> there is a failure in the Dispatcher for the Stomp connection and my client
> stops receiving messages.  The OpenWire connection is unaffected and
> continues filling the Queue.  I have since upgraded to ActiveMQ 5.3 because
> there were some issues fixed related to Stomp connection, but still see the
> same issue.  The only exception that is displayed in the log is at the
> bottom of this post.
>
> I'm going to continue to look for a test case to reproduce my error, but in
> the mean time thought I would poll the experts for some advice.
>
> Thanks,
> Ben
>
> Exception in thread "ActiveMQ Connection Dispatcher: /127.0.0.1:3047"
> java.lang.NullPointerException
>
>        at
>
> org.apache.activemq.transport.stomp.LegacyFrameTranslator.convertMessage(LegacyFrameTranslator.java:69)
>        at
>
> org.apache.activemq.transport.stomp.ProtocolConverter.convertMessage(ProtocolConverter.java:594)
>        at
>
> org.apache.activemq.transport.stomp.StompSubscription.onMessageDispatch(StompSubscription.java:92)
>        at
>
> org.apache.activemq.transport.stomp.ProtocolConverter.onActiveMQCommand(ProtocolConverter.java:576)
>        at
>
> org.apache.activemq.transport.stomp.StompTransportFilter.oneway(StompTransportFilter.java:56)
>        at
> org.apache.activemq.transport.MutexTransport.oneway(MutexTransport.java:40)
>        at
>
> org.apache.activemq.broker.TransportConnection.dispatch(TransportConnection.java:1190)
>        at
>
> org.apache.activemq.broker.TransportConnection.processDispatch(TransportConnection.java:779)
>        at
>
> org.apache.activemq.broker.TransportConnection.iterate(TransportConnection.java:815)
>        at
>
> org.apache.activemq.thread.DedicatedTaskRunner.runTask(DedicatedTaskRunner.java:98)
>        at
>
> org.apache.activemq.thread.DedicatedTaskRunner$1.run(DedicatedTaskRunner.java:36)
> --
> View this message in context:
> http://old.nabble.com/Stomp-Connection-Dispatcher-Fails-on-NPE-tp26216237p26216237.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message